summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-28 20:05:35 +0200
committerMartchus2016-03-28 20:05:35 +0200
commitf27efaec1d06530137ac3bbaef6b7e7c855ebc4e (patch)
tree001fe070bcbe2924ced206d9006d1d8db9af6ad0
downloadaur-f27efaec1d06530137ac3bbaef6b7e7c855ebc4e.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD54
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e015f67beb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Mar 28 18:05:18 UTC 2016
+pkgbase = mingw-w64-qt5-canvas3d
+ pkgdesc = A JavaScript 3D rendering API for Qt Quick (mingw-w64)
+ pkgver = 5.6.0
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qtcanvas3d-opensource-src-5.6.0.tar.xz
+ md5sums = 73ca1057b64bc99299d2e55c1a35f469
+
+pkgname = mingw-w64-qt5-canvas3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1d1313e46b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_qt_module=qtcanvas3d
+pkgname="mingw-w64-qt5-canvas3d"
+pkgver=5.6.0
+pkgrel=1
+arch=('any')
+pkgdesc="A JavaScript 3D rendering API for Qt Quick (mingw-w64)"
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="https://www.qt.io/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('73ca1057b64bc99299d2e55c1a35f469')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ # install manually to get the import lib, too
+ install -Dm755 qml/QtCanvas3D/*.dll -t "${pkgdir}/usr/${_arch}/bin"
+ install -Dm644 qml/QtCanvas3D/*.dll.a -t "${pkgdir}/usr/${_arch}/lib"
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}