summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-19 22:10:36 +0200
committerMartchus2016-08-19 22:10:36 +0200
commit8c3db85b6644178ccdc8439a2081626ed9c9d7c1 (patch)
tree66262c8b091c7064f12faeebf7f7aec12bd9d3fc
parent3e81d991bd95bc1e7b8f96835d6d84100319db9e (diff)
downloadaur-8c3db85b6644178ccdc8439a2081626ed9c9d7c1.tar.gz
Add static version of further Qt modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD54
2 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f881e76a8f2..911816fe4433 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:36:07 UTC 2016
+# Fri Aug 19 20:10:35 UTC 2016
pkgbase = mingw-w64-qt5-charts
pkgdesc = Provides a set of easy to use chart components (mingw-w64)
pkgver = 5.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = any
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
makedepends = mingw-w64-qt5-declarative
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
optdepends = mingw-w64-qt5-declarative: QML bindings
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index eb6cfd377950..fd8c2b038bb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
_qt_module=qtcharts
pkgname="mingw-w64-qt5-charts"
pkgver=5.7.0
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Provides a set of easy to use chart components (mingw-w64)"
depends=('mingw-w64-qt5-base')
@@ -19,18 +22,25 @@ _pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
md5sums=('9b4f6931c946b8dc1fad97bf8c30f485')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=shared')
build() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
-
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
-
- popd
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ make
+ popd
+ done
done
}
@@ -38,20 +48,20 @@ package() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
- pushd build-${_arch}
-
- make INSTALL_ROOT="${pkgdir}" install
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
-
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
-
- popd
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
done
-
- # .prl files aren't interesting for us
- find "${pkgdir}" -name "*.prl" -delete
}