summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:18 +0100
committerMartchus2018-02-19 20:15:18 +0100
commitc61691a7181fb2deb619dbd2177153367fd335f5 (patch)
treec32a6227bb1528e753d3ccbf34843f977f103507
parentaec5ae50637d828e1ae75d54597fc5733d0c4142 (diff)
downloadaur-c61691a7181fb2deb619dbd2177153367fd335f5.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98fe977ae18a..dd6ad6097356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:29 UTC 2017
+# Mon Feb 19 19:15:18 UTC 2018
pkgbase = mingw-w64-qt5-charts
pkgdesc = Provides a set of easy to use chart components (mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -21,8 +21,8 @@ pkgbase = mingw-w64-qt5-charts
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtcharts-everywhere-src-5.10.0.tar.xz
- sha256sums = 12ce2c4a8467d349ecfdba831cc03c539f2b207aa21082a4e1043dcf8f1b31ef
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtcharts-everywhere-src-5.10.1.tar.xz
+ sha256sums = 4f0d577bf73dd2bbb2765c2cfb493a2d68790fc2c64f42544d31dba806321ec9
pkgname = mingw-w64-qt5-charts
diff --git a/PKGBUILD b/PKGBUILD
index 3e079ba5767e..cf551c47ed6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_qt_module=qtcharts
pkgname="mingw-w64-qt5-charts"
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc="Provides a set of easy to use chart components (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('12ce2c4a8467d349ecfdba831cc03c539f2b207aa21082a4e1043dcf8f1b31ef')
+sha256sums=('4f0d577bf73dd2bbb2765c2cfb493a2d68790fc2c64f42544d31dba806321ec9')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -53,6 +53,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
@@ -64,5 +77,8 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}