summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:10:03 +0100
committerMartchus2020-01-29 19:10:03 +0100
commit765d44daa720f74749c01f55218d6eae57ca7586 (patch)
tree8939d83c3b81399c045567c11c6b8874fb941c54
parent590ee29312c5cc808b3b9b26a37251c5dbff41d1 (diff)
downloadaur-765d44daa720f74749c01f55218d6eae57ca7586.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-case-of-setupapi.h-for-mingw-w64.patch4
-rw-r--r--PKGBUILD22
-rw-r--r--PKGBUILD.sh.ep9
-rw-r--r--qtconnectivity-sha256.txt1
5 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a996318dba7..e8c8650fdc32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-connectivity
pkgdesc = Provides access to Bluetooth hardware (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -18,10 +18,10 @@ pkgbase = mingw-w64-qt5-connectivity
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtconnectivity-everywhere-src-5.14.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtconnectivity-everywhere-src-5.14.1.tar.xz
source = 0001-Fix-case-of-setupapi.h-for-mingw-w64.patch
- sha256sums = 2843b3b479d0feba0624eb4ae41382b99db77b87a6b7dea5aacdf3b33644f0bd
- sha256sums = b5b231fa866711f69107a4b0c65e79acf82986cb0c0e0c1184ef79ef46d79518
+ sha256sums = ef0cb1883c0e765cacf6c8b9422997b93fd861cf2289e56791615401eefa2d72
+ sha256sums = f78533cd673d15d81b8ab136c892d7e1b61569bb84b48b27345dfa8d6dc3123b
pkgname = mingw-w64-qt5-connectivity
diff --git a/0001-Fix-case-of-setupapi.h-for-mingw-w64.patch b/0001-Fix-case-of-setupapi.h-for-mingw-w64.patch
index db4b8eecfef0..02e348f73d9a 100644
--- a/0001-Fix-case-of-setupapi.h-for-mingw-w64.patch
+++ b/0001-Fix-case-of-setupapi.h-for-mingw-w64.patch
@@ -1,4 +1,4 @@
-From 858c34d0ed8eed8fe1c9d1108760d6ab51ef2e89 Mon Sep 17 00:00:00 2001
+From 7c08a83848ab4102d2ec4a98c503c7ace26e3e24 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Tue, 24 Dec 2019 13:06:11 +0100
Subject: [PATCH] Fix case of setupapi.h for mingw-w64
@@ -21,5 +21,5 @@ index ced69685..7a30be9a 100644
QT_BEGIN_NAMESPACE
--
-2.24.1
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index 1a742ee7b91b..ff1649e0786d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,39 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtconnectivity
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtconnectivity
-pkgname="mingw-w64-qt5-connectivity"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-connectivity
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Provides access to Bluetooth hardware (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-case-of-setupapi.h-for-mingw-w64.patch')
-sha256sums=('2843b3b479d0feba0624eb4ae41382b99db77b87a6b7dea5aacdf3b33644f0bd'
- 'b5b231fa866711f69107a4b0c65e79acf82986cb0c0e0c1184ef79ef46d79518')
+sha256sums=('ef0cb1883c0e765cacf6c8b9422997b93fd861cf2289e56791615401eefa2d72'
+ 'f78533cd673d15d81b8ab136c892d7e1b61569bb84b48b27345dfa8d6dc3123b')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -41,7 +48,6 @@ prepare() {
done
}
-
build() {
cd "${srcdir}/${_pkgfqn}"
@@ -49,7 +55,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..0a9838db0c9a
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,9 @@
+% layout 'mingw-w64-qt5-module';
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Provides access to Bluetooth hardware (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
diff --git a/qtconnectivity-sha256.txt b/qtconnectivity-sha256.txt
new file mode 100644
index 000000000000..5aa118ad3e81
--- /dev/null
+++ b/qtconnectivity-sha256.txt
@@ -0,0 +1 @@
+ef0cb1883c0e765cacf6c8b9422997b93fd861cf2289e56791615401eefa2d72