summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-28 20:04:49 +0200
committerMartchus2016-03-28 20:04:49 +0200
commitbf9b111a553823692d181221d996125f5297eb0d (patch)
tree81a1fef87a5737169bc8b5a36f67c1c084522ef0
downloadaur-bf9b111a553823692d181221d996125f5297eb0d.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD56
-rw-r--r--PKGBUILD.bak54
3 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9312514aac4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Mar 28 18:04:31 UTC 2016
+pkgbase = mingw-w64-qt5-connectivity
+ pkgdesc = Provides access to Bluetooth hardware (mingw-w64)
+ pkgver = 5.6.0
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-declarative
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qtconnectivity-opensource-src-5.6.0.tar.xz
+ md5sums = 38589e8f50dbf835db4fdb5da32a7114
+
+pkgname = mingw-w64-qt5-connectivity
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93afc87c4fee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_qt_module=qtconnectivity
+pkgname="mingw-w64-qt5-connectivity"
+pkgver=5.6.0
+pkgrel=1
+arch=('any')
+pkgdesc="Provides access to Bluetooth hardware (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-qt5-declarative')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="https://www.qt.io/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('38589e8f50dbf835db4fdb5da32a7114')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}
diff --git a/PKGBUILD.bak b/PKGBUILD.bak
new file mode 100644
index 000000000000..1d96b7749314
--- /dev/null
+++ b/PKGBUILD.bak
@@ -0,0 +1,54 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+
+_qt_module=qt3d
+pkgname="mingw-w64-qt5-3d"
+pkgver=5.5.1
+pkgrel=1
+arch=('any')
+pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
+depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative' 'mingw-w64-qt5-quick1')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="https://www.qt.io/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('872dfbe166154c2e0e89317ab23d2cd6')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}