summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-06-08 21:42:42 +0200
committerMartchus2017-06-08 21:42:42 +0200
commit0353c33159e94d7671c3ae3785a829bb65ed2941 (patch)
tree7005c55227f6f75f879f096107fe514875e5714d
parent5eead6ce6724e5d31b9466d6de6c45999562357f (diff)
downloadaur-0353c33159e94d7671c3ae3785a829bb65ed2941.tar.gz
Update to 5.9.0
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Build-QML-dev-tools-as-shared-library.patch24
-rw-r--r--0002-Ensure-static-plugins-are-exported.patch4
-rw-r--r--0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch22
-rwxr-xr-xPKGBUILD10
5 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c90dd6e532d..1158469c2f22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 4 16:47:23 UTC 2017
+# Thu Jun 8 19:42:42 UTC 2017
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.8.0
+ pkgver = 5.9.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -21,14 +21,14 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.8/5.8.0/submodules/qtdeclarative-opensource-src-5.8.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.9/5.9.0/submodules/qtdeclarative-opensource-src-5.9.0.tar.xz
source = 0001-Build-QML-dev-tools-as-shared-library.patch
source = 0002-Ensure-static-plugins-are-exported.patch
source = 0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
- md5sums = 4f55b3617abdff14706d02d761d5a0aa
- md5sums = 8739ad352da4053430efb01fadff2a52
- md5sums = bfa8bbcc3b92bf8fe7e15266ba195380
- md5sums = 8bf08d300c039dbdd58bab8b602eb175
+ sha256sums = 3c9b72098f952155e943c4890c67f9a7dd81737ff69b482a401a2b2af0f93ebd
+ sha256sums = ff9799217cfa4f0a1abac8c91680f1df45e04f5519e3cbd01be9cb3586ba89b4
+ sha256sums = 1b7795c7faf53e9a8125a74787949b42ca8b6c0e6466c40e4ab5116c1186a5ec
+ sha256sums = 2afae3fea54f46ecca6719ab81c59cd3bf9a9207e03c3026f376ede456aa054e
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Build-QML-dev-tools-as-shared-library.patch b/0001-Build-QML-dev-tools-as-shared-library.patch
index c238beda506a..33e535da6a9a 100644
--- a/0001-Build-QML-dev-tools-as-shared-library.patch
+++ b/0001-Build-QML-dev-tools-as-shared-library.patch
@@ -1,25 +1,27 @@
-From 9c2df30c4438c8741258cdef5ecb13bcf62b8d76 Mon Sep 17 00:00:00 2001
+From 40a42fb5a19193cf6b4610ae753135f5fe855967 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:24:15 +0200
Subject: [PATCH 1/3] Build QML dev tools as shared library
---
- src/qmldevtools/qmldevtools.pro | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ src/qmldevtools/qmldevtools.pro | 4 ++++
+ 1 file changed, 4 insertions(+)
diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
-index acd5c9729..8b7b999d0 100644
+index a21988b91..fc5c4d05d 100644
--- a/src/qmldevtools/qmldevtools.pro
+++ b/src/qmldevtools/qmldevtools.pro
-@@ -1,7 +1,7 @@
- option(host_build)
+@@ -2,6 +2,10 @@ option(host_build)
TARGET = QtQmlDevTools
QT = core-private
--CONFIG += static internal_module qmldevtools_build
-+CONFIG += internal_module qmldevtools_build
+ CONFIG += minimal_syncqt internal_module qmldevtools_build
++win32:!contains(CONFIG, static) {
++ CONFIG += shared
++ CONFIG -= static staticlib
++}
+
+ MODULE_INCNAME = QtQml
- # Don't use pch because the auto-generated header refers to QtBootstrap,
- # which doesn't exist
--
-2.11.0
+2.13.0
diff --git a/0002-Ensure-static-plugins-are-exported.patch b/0002-Ensure-static-plugins-are-exported.patch
index 6946b707bbfd..088cb8eeee5c 100644
--- a/0002-Ensure-static-plugins-are-exported.patch
+++ b/0002-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From b480b775adc7224a83338356a9228bed5d538618 Mon Sep 17 00:00:00 2001
+From b2d3ca2ecd3a9ea852655b2d117636ba54e5854d Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 2/3] Ensure static plugins are exported
@@ -18,5 +18,5 @@ index 9ddb9885c..9775d85e0 100644
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
-2.11.0
+2.13.0
diff --git a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index f69fd721e504..3356c889d06a 100644
--- a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From 8b4bae62d27ed0eb5df5dd06653b76f4890eb409 Mon Sep 17 00:00:00 2001
+From b4536a7f6e229d3d0309e65a71d0ccb93db8bc6e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 3/3] Prevent exporting QML parser symbols on static build
@@ -8,7 +8,7 @@ Subject: [PATCH 3/3] Prevent exporting QML parser symbols on static build
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/qml/parser/qqmljsglobal_p.h b/src/qml/parser/qqmljsglobal_p.h
-index 933c8f520..914a5b5e8 100644
+index 0e195994b..8aa451e9d 100644
--- a/src/qml/parser/qqmljsglobal_p.h
+++ b/src/qml/parser/qqmljsglobal_p.h
@@ -56,9 +56,9 @@
@@ -16,22 +16,22 @@ index 933c8f520..914a5b5e8 100644
# define QT_QML_END_NAMESPACE
-# ifdef QDECLARATIVEJS_BUILD_DIR
-+# if defined(QDECLARATIVEJS_BUILD_DIR) || !defined(QT_STATIC)
++# if defined(QDECLARATIVEJS_BUILD_DIR) && !defined(QT_STATIC)
# define QML_PARSER_EXPORT Q_DECL_EXPORT
-# elif QML_BUILD_STATIC_LIB
+# elif defined(QML_BUILD_STATIC_LIB) || defined(QT_STATIC)
# define QML_PARSER_EXPORT
# else
# define QML_PARSER_EXPORT Q_DECL_IMPORT
-@@ -67,7 +67,7 @@
- #else // !QT_CREATOR
+@@ -68,7 +68,7 @@
# define QT_QML_BEGIN_NAMESPACE QT_BEGIN_NAMESPACE
# define QT_QML_END_NAMESPACE QT_END_NAMESPACE
--# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB)
-+# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB) || defined(QT_STATIC)
- // QmlDevTools is a static library
- # define QML_PARSER_EXPORT
- # elif defined(QT_BUILD_QML_LIB)
+ # ifndef QT_STATIC
+-# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB)
++# if defined(QT_BUILD_QMLDEVTOOLS_LIB) || defined(QT_QMLDEVTOOLS_LIB) || defined(QT_STATIC)
+ // QmlDevTools is a static library
+ # define QML_PARSER_EXPORT
+ # elif defined(QT_BUILD_QML_LIB)
--
-2.11.0
+2.13.0
diff --git a/PKGBUILD b/PKGBUILD
index e46a57487e6d..611e2998a25b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.8.0
+pkgver=5.9.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -27,10 +27,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
'0001-Build-QML-dev-tools-as-shared-library.patch'
'0002-Ensure-static-plugins-are-exported.patch'
'0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-md5sums=('4f55b3617abdff14706d02d761d5a0aa'
- '8739ad352da4053430efb01fadff2a52'
- 'bfa8bbcc3b92bf8fe7e15266ba195380'
- '8bf08d300c039dbdd58bab8b602eb175')
+sha256sums=('3c9b72098f952155e943c4890c67f9a7dd81737ff69b482a401a2b2af0f93ebd'
+ 'ff9799217cfa4f0a1abac8c91680f1df45e04f5519e3cbd01be9cb3586ba89b4'
+ '1b7795c7faf53e9a8125a74787949b42ca8b6c0e6466c40e4ab5116c1186a5ec'
+ '2afae3fea54f46ecca6719ab81c59cd3bf9a9207e03c3026f376ede456aa054e')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \