summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-12-08 20:41:02 +0100
committerMartchus2016-12-08 20:41:02 +0100
commit60ca043a8ff362bc772574599c0e169aed15b3ed (patch)
treecb9ee4ad4f26a42d3ce38643af00b5472b208193
parent8941cbd2337ef7fe5eca54195f1cac36c2a9a143 (diff)
downloadaur-60ca043a8ff362bc772574599c0e169aed15b3ed.tar.gz
Fix misc issues
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Build-QML-dev-tools-as-shared-library.patch25
-rw-r--r--0002-Fix-i686-segfaults-with-GCC-6.patch27
-rw-r--r--0003-Ensure-static-plugins-are-exported.patch22
-rwxr-xr-xPKGBUILD25
5 files changed, 96 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33929018ee2c..57d37b607bad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 20:10:09 UTC 2016
+# Thu Dec 8 19:40:56 UTC 2016
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
pkgver = 5.7.0
- pkgrel = 2
+ pkgrel = 6
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -22,11 +22,13 @@ pkgbase = mingw-w64-qt5-declarative
options = !buildflags
options = staticlibs
source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtdeclarative-opensource-src-5.7.0.tar.xz
- source = qt5-build-qmldevtools-as-shared-library.patch
- source = qt5-declarative-gcc6.patch
+ source = 0001-Build-QML-dev-tools-as-shared-library.patch
+ source = 0002-Fix-i686-segfaults-with-GCC-6.patch
+ source = 0003-Ensure-static-plugins-are-exported.patch
md5sums = 0d9e461aa54dba4793253fa2eb501f9b
- md5sums = 8f90ec8c2379b85de0b04847865b230c
- md5sums = fb2a2a118b356a0a4635111f2e0b0ee6
+ md5sums = 1d70fdbe290a1c0d2562cd975224c219
+ md5sums = a11b3a584566e144a821c66f8ec53e26
+ md5sums = 8d6740a6fad763f2c42c9c56022f8567
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Build-QML-dev-tools-as-shared-library.patch b/0001-Build-QML-dev-tools-as-shared-library.patch
new file mode 100644
index 000000000000..296655ca4f21
--- /dev/null
+++ b/0001-Build-QML-dev-tools-as-shared-library.patch
@@ -0,0 +1,25 @@
+From 4fb746894af3a46afcc117aa48c20b0440e002b2 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:24:15 +0200
+Subject: [PATCH 1/3] Build QML dev tools as shared library
+
+---
+ src/qmldevtools/qmldevtools.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
+index acd5c97..8b7b999 100644
+--- a/src/qmldevtools/qmldevtools.pro
++++ b/src/qmldevtools/qmldevtools.pro
+@@ -1,7 +1,7 @@
+ option(host_build)
+ TARGET = QtQmlDevTools
+ QT = core-private
+-CONFIG += static internal_module qmldevtools_build
++CONFIG += internal_module qmldevtools_build
+
+ # Don't use pch because the auto-generated header refers to QtBootstrap,
+ # which doesn't exist
+--
+2.10.1
+
diff --git a/0002-Fix-i686-segfaults-with-GCC-6.patch b/0002-Fix-i686-segfaults-with-GCC-6.patch
new file mode 100644
index 000000000000..1f4fc4f5e522
--- /dev/null
+++ b/0002-Fix-i686-segfaults-with-GCC-6.patch
@@ -0,0 +1,27 @@
+From cbfa366cae825ec25d1ce5799d64cfa6b79b1ac2 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:25:03 +0200
+Subject: [PATCH 2/3] Fix i686 segfaults with GCC 6
+
+- Fedora patch
+- See: https://bugreports.qt.io/browse/QTBUG-52057
+---
+ src/qml/qml.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qml/qml.pro b/src/qml/qml.pro
+index f4862a1..651afa6 100644
+--- a/src/qml/qml.pro
++++ b/src/qml/qml.pro
+@@ -18,7 +18,7 @@ exists("qqml_enable_gcov") {
+
+ greaterThan(QT_GCC_MAJOR_VERSION, 5) {
+ # Our code is bad. Temporary workaround.
+- QMAKE_CXXFLAGS += -fno-delete-null-pointer-checks
++ QMAKE_CXXFLAGS += -fno-delete-null-pointer-checks -fno-lifetime-dse
+ }
+
+ QMAKE_DOCS = $$PWD/doc/qtqml.qdocconf
+--
+2.10.1
+
diff --git a/0003-Ensure-static-plugins-are-exported.patch b/0003-Ensure-static-plugins-are-exported.patch
new file mode 100644
index 000000000000..6e9533a71a4e
--- /dev/null
+++ b/0003-Ensure-static-plugins-are-exported.patch
@@ -0,0 +1,22 @@
+From 1229bfe0d4468f929c224e19800d690372245af0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 23 Oct 2016 01:18:13 +0200
+Subject: [PATCH 3/3] Ensure static plugins are exported
+
+---
+ src/qml/Qt5QmlConfigExtras.cmake.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qml/Qt5QmlConfigExtras.cmake.in b/src/qml/Qt5QmlConfigExtras.cmake.in
+index 9ddb988..9775d85 100644
+--- a/src/qml/Qt5QmlConfigExtras.cmake.in
++++ b/src/qml/Qt5QmlConfigExtras.cmake.in
+@@ -1,4 +1,4 @@
+-file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/Qt5Qml_*Factory.cmake")
++file(GLOB _qt5qml_other_plugins "${CMAKE_CURRENT_LIST_DIR}/*Qt5Qml_*Factory.cmake")
+
+ foreach(_other_plugin ${_qt5qml_other_plugins})
+ include(${_other_plugin} OPTIONAL)
+--
+2.10.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 0b1906890143..c74051f20275 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,14 @@
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+# All patches are managed at https://github.com/Martchus/qtdeclarative
+
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
pkgver=5.7.0
-pkgrel=2
+pkgrel=6
arch=('i686' 'x86_64')
-pkgdesc="Classes for QML and JavaScript languages (mingw-w64)"
+pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'python')
options=(!strip !buildflags staticlibs)
@@ -22,11 +24,13 @@ license=('GPL3' 'LGPL3' 'FDL' 'custom')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qt5-build-qmldevtools-as-shared-library.patch"
- "qt5-declarative-gcc6.patch")
+ '0001-Build-QML-dev-tools-as-shared-library.patch'
+ '0002-Fix-i686-segfaults-with-GCC-6.patch'
+ '0003-Ensure-static-plugins-are-exported.patch')
md5sums=('0d9e461aa54dba4793253fa2eb501f9b'
- '8f90ec8c2379b85de0b04847865b230c'
- 'fb2a2a118b356a0a4635111f2e0b0ee6')
+ '1d70fdbe290a1c0d2562cd975224c219'
+ 'a11b3a584566e144a821c66f8ec53e26'
+ '8d6740a6fad763f2c42c9c56022f8567')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -39,11 +43,10 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # Build native/non-cross library Qt5QmlDevTools as shared library
- patch -p1 -i "${srcdir}"/qt5-build-qmldevtools-as-shared-library.patch
-
- # Fix i686 segfaults with GCC 6 https://bugreports.qt.io/browse/QTBUG-52057 (Fedora patch)
- patch -p1 -i "${srcdir}"/qt5-declarative-gcc6.patch
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
}
build() {