summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-08-26 21:25:46 -0600
committerPhilip A Reimer2015-08-26 21:25:46 -0600
commit6ff0d4579a0ceb2e6e62fa3fe8334b1980e666cd (patch)
tree96abd5e578491be44142ec614e059ec22ca78615
parent9ffddb317be0eb6e99423ce359ab9e3860494395 (diff)
downloadaur-6ff0d4579a0ceb2e6e62fa3fe8334b1980e666cd.tar.gz
update .SRCINFO
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD8
-rw-r--r--qt5-build-qmldevtools-as-shared-library.patch8
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5feb6ee28f26..92561336dcc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.4.2
+ pkgver = 5.5.0
pkgrel = 1
url = http://qt-project.org
arch = any
@@ -13,10 +13,10 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = http://download.qt-project.org/official_releases/qt/5.4/5.4.2/submodules/qtdeclarative-opensource-src-5.4.2.tar.xz
+ source = http://download.qt-project.org/official_releases/qt/5.5/5.5.0/submodules/qtdeclarative-opensource-src-5.5.0.tar.xz
source = qt5-build-qmldevtools-as-shared-library.patch
- md5sums = 5b257cd097c315dab1b3c15e26211823
- md5sums = 9caacc92a58eb05c3567ecc67ba433c4
+ md5sums = 1452c92f8c660dc7d23d9e17d89f8716
+ md5sums = 6c445ba7713b69d90f52bb2242303853
pkgname = mingw-w64-qt5-declarative
diff --git a/PKGBUILD b/PKGBUILD
index 7dd824ed14e2..11c7f3d29d66 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.4.2
+pkgver=5.5.0
pkgrel=1
arch=(any)
pkgdesc="Classes for QML and JavaScript languages (mingw-w64)"
@@ -12,10 +12,10 @@ groups=(mingw-w64-qt mingw-w64-qt5)
license=("custom, FDL, GPL3, LGPL")
url="http://qt-project.org"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+source=("http://download.qt-project.org/official_releases/qt/5.5/${pkgver}/submodules/${_pkgfqn}.tar.xz"
"qt5-build-qmldevtools-as-shared-library.patch")
-md5sums=('5b257cd097c315dab1b3c15e26211823'
- '9caacc92a58eb05c3567ecc67ba433c4')
+md5sums=('1452c92f8c660dc7d23d9e17d89f8716'
+ '6c445ba7713b69d90f52bb2242303853')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/qt5-build-qmldevtools-as-shared-library.patch b/qt5-build-qmldevtools-as-shared-library.patch
index ef7626b70819..f8a120f5457b 100644
--- a/qt5-build-qmldevtools-as-shared-library.patch
+++ b/qt5-build-qmldevtools-as-shared-library.patch
@@ -4,8 +4,8 @@
option(host_build)
TARGET = QtQmlDevTools
QT = core
--CONFIG += static no_module_headers internal_module qmldevtools_build
-+CONFIG += no_module_headers internal_module qmldevtools_build
+-CONFIG += static internal_module qmldevtools_build
++CONFIG += internal_module qmldevtools_build
- MODULE_INCLUDES = \
- \$\$QT_MODULE_INCLUDE_BASE \
+ # Don't use pch because the auto-generated header refers to QtBootstrap,
+ # which doesn't exist