summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-12-11 18:57:38 +0000
committerMartchus2018-12-11 18:57:38 +0000
commita426686c46d48d3fb5b9d758c4ff7a865124a415 (patch)
tree917873a0308bb1f1c7a2d706662039e4a4c252d6
parentc56fd137a1f428e5c2e8235092ff0bf16e5a4c30 (diff)
downloadaur-a426686c46d48d3fb5b9d758c4ff7a865124a415.tar.gz
Update to 5.12.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Ensure-QML-dev-tools-is-built-as-static-library.patch8
-rw-r--r--0002-Ensure-static-plugins-are-exported.patch4
-rw-r--r--0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch4
-rwxr-xr-xPKGBUILD10
5 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66b388730898..01ea08d994a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.11.2
+ pkgver = 5.12.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -19,14 +19,14 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.11/5.11.2/submodules/qtdeclarative-everywhere-src-5.11.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.12/5.12.0/submodules/qtdeclarative-everywhere-src-5.12.0.tar.xz
source = 0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
source = 0002-Ensure-static-plugins-are-exported.patch
source = 0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
- sha256sums = 220d86f8031e9d45f3c369c3fd517aaa4c5783ad62c843a21fa7cc3c0a36f2cd
- sha256sums = 4544a494437fd73a17053738d38bbd857a081846ad2cd4db0047706961aa4cee
- sha256sums = 4d5799f9cc322ba5379b3e7ec57ead3001e1dbd2bc6b9d225e6fb1d8a9b4cab6
- sha256sums = e390fc1f78f9e752f6f41bd2f15a7470c6359b21954e08c9bfba89514f7a89d5
+ sha256sums = 4ffd58102b5714ae058f91cc31511f1c928978f77f01652beb9ce2352a4c227b
+ sha256sums = 2d7d6a17b76deac8761fc1a9f2792b727dde2489567e32e974e109c95e13d88a
+ sha256sums = 04b397535c09bfd23b4c85d4b27084d2eaba5daa0e06d027611f67be6bd79e20
+ sha256sums = f1edd14697cacd6e6bebb8060d93e4ccc96fd0ff7b1c6c0ba07842878a20e9e3
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch b/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
index 6387ef853b8f..55da79d8a21d 100644
--- a/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
+++ b/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
@@ -1,4 +1,4 @@
-From 4c4238006e25d132cc51055c3d18f5d55528d843 Mon Sep 17 00:00:00 2001
+From 9790dd08de71b65598da3b0972b522e4ef6ba5d5 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:24:15 +0200
Subject: [PATCH 1/3] Ensure QML dev tools is built as static library
@@ -10,18 +10,18 @@ using CONFIG+=shared. Otherwise it fails to link.
1 file changed, 2 insertions(+)
diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
-index 23b7cf651..d48a36059 100644
+index 05aa6f66f..e73c0c23d 100644
--- a/src/qmldevtools/qmldevtools.pro
+++ b/src/qmldevtools/qmldevtools.pro
@@ -2,6 +2,8 @@ option(host_build)
TARGET = QtQmlDevTools
QT = core-private
- CONFIG += minimal_syncqt internal_module qmldevtools_build
+ CONFIG += minimal_syncqt internal_module qmldevtools_build generated_privates
+CONFIG -= shared
+CONFIG += static staticlib
MODULE_INCNAME = QtQml
INCLUDEPATH += $$OUT_PWD/../qml
--
-2.19.0
+2.19.2
diff --git a/0002-Ensure-static-plugins-are-exported.patch b/0002-Ensure-static-plugins-are-exported.patch
index 98ba5dff2c49..601af5383781 100644
--- a/0002-Ensure-static-plugins-are-exported.patch
+++ b/0002-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From 026bfb5c650fc8e4306dd70bfcc857f45b883b31 Mon Sep 17 00:00:00 2001
+From 3dd645e6d2c9b68df74f78ec62339a744333c438 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 2/3] Ensure static plugins are exported
@@ -18,5 +18,5 @@ index 9ddb9885c..9775d85e0 100644
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
-2.19.0
+2.19.2
diff --git a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index e09ab0b49155..4df328a9629c 100644
--- a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From ef8f7050ae1830fad4984c8fd4ffce858184118e Mon Sep 17 00:00:00 2001
+From 1a8c381d6e36a0b0525926e3bbfa87b863cbbc5c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 3/3] Prevent exporting QML parser symbols on static build
@@ -33,5 +33,5 @@ index 0e195994b..8aa451e9d 100644
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
-2.19.0
+2.19.2
diff --git a/PKGBUILD b/PKGBUILD
index 91c17a4a1d04..c6667152dd5b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.11.2
+pkgver=5.12.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -27,10 +27,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/subm
'0001-Ensure-QML-dev-tools-is-built-as-static-library.patch'
'0002-Ensure-static-plugins-are-exported.patch'
'0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-sha256sums=('220d86f8031e9d45f3c369c3fd517aaa4c5783ad62c843a21fa7cc3c0a36f2cd'
- '4544a494437fd73a17053738d38bbd857a081846ad2cd4db0047706961aa4cee'
- '4d5799f9cc322ba5379b3e7ec57ead3001e1dbd2bc6b9d225e6fb1d8a9b4cab6'
- 'e390fc1f78f9e752f6f41bd2f15a7470c6359b21954e08c9bfba89514f7a89d5')
+sha256sums=('4ffd58102b5714ae058f91cc31511f1c928978f77f01652beb9ce2352a4c227b'
+ '2d7d6a17b76deac8761fc1a9f2792b727dde2489567e32e974e109c95e13d88a'
+ '04b397535c09bfd23b4c85d4b27084d2eaba5daa0e06d027611f67be6bd79e20'
+ 'f1edd14697cacd6e6bebb8060d93e4ccc96fd0ff7b1c6c0ba07842878a20e9e3')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \