summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-05-28 21:54:38 +0200
committerMartchus2018-05-28 21:54:38 +0200
commitbc6e63a4f82c4036dc54d672717dc3d8ce980238 (patch)
tree3fc57f184992c57d546e633143682007dc66e76d
parent744aa4049b599b65369c071c5ec3c1dd2ddbec8b (diff)
downloadaur-bc6e63a4f82c4036dc54d672717dc3d8ce980238.tar.gz
Update to 5.11.0
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Build-QML-dev-tools-as-shared-library.patch27
-rw-r--r--0001-Ensure-QML-dev-tools-is-built-as-static-library.patch27
-rw-r--r--0002-Ensure-static-plugins-are-exported.patch4
-rw-r--r--0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch4
-rw-r--r--[-rwxr-xr-x]PKGBUILD52
6 files changed, 71 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2535172cb05..e9d8a0261e79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 19 19:15:12 UTC 2018
pkgbase = mingw-w64-qt5-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 5.10.1
+ pkgver = 5.11.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -21,14 +19,14 @@ pkgbase = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtdeclarative-everywhere-src-5.10.1.tar.xz
- source = 0001-Build-QML-dev-tools-as-shared-library.patch
+ source = https://download.qt.io/official_releases/qt/5.11/5.11.0/submodules/qtdeclarative-everywhere-src-5.11.0.tar.xz
+ source = 0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
source = 0002-Ensure-static-plugins-are-exported.patch
source = 0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
- sha256sums = 3af9ed51bce5b5c6f04c4a67a6008f98765ccde897c43fff670621ab70789553
- sha256sums = 777da4ec89376e654d9088ec70e3c5154dd8e31fa8de6f1f77f2d7d5f10bcd9b
- sha256sums = e9afee84dfde3275807cc9b2eb1fb23b5074a12b8f896bd02d8b8f9963d545a6
- sha256sums = cbf3675f3072bbab29fdf5541fd3c15986567a127f920cdaddcfff9e6a9d0283
+ sha256sums = eea9378b17b1c16d3b5235629b9128349bf98cba7d9c61122653d976b25f57c0
+ sha256sums = 95bf80aa39a9705d84d3cfe73b5de0540f2aa5853645f170d47cfa7ef8bd0074
+ sha256sums = 182808bb60fcef2397e2e2476d1a86a43945f89cf653b58f2a6b6bf82e8cfe1e
+ sha256sums = b629fa778ef275f07eb3cf224c0584813bd1825e005823307e0690ad4c8e1326
pkgname = mingw-w64-qt5-declarative
diff --git a/0001-Build-QML-dev-tools-as-shared-library.patch b/0001-Build-QML-dev-tools-as-shared-library.patch
deleted file mode 100644
index 09eea8757353..000000000000
--- a/0001-Build-QML-dev-tools-as-shared-library.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 3135dd89f17e198eab5b3739fd7fcd6b8d51a914 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Sun, 25 Sep 2016 21:24:15 +0200
-Subject: [PATCH 1/3] Build QML dev tools as shared library
-
----
- src/qmldevtools/qmldevtools.pro | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
-index a21988b91..fc5c4d05d 100644
---- a/src/qmldevtools/qmldevtools.pro
-+++ b/src/qmldevtools/qmldevtools.pro
-@@ -2,6 +2,10 @@ option(host_build)
- TARGET = QtQmlDevTools
- QT = core-private
- CONFIG += minimal_syncqt internal_module qmldevtools_build
-+win32:!contains(CONFIG, static) {
-+ CONFIG += shared
-+ CONFIG -= static staticlib
-+}
-
- MODULE_INCNAME = QtQml
-
---
-2.16.1
-
diff --git a/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch b/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
new file mode 100644
index 000000000000..8949f198b599
--- /dev/null
+++ b/0001-Ensure-QML-dev-tools-is-built-as-static-library.patch
@@ -0,0 +1,27 @@
+From 8cfa15af4358dc4043e19b8bd06bc2ddcfaca9fa Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:24:15 +0200
+Subject: [PATCH 1/3] Ensure QML dev tools is built as static library
+
+This library must be built as static library even when
+using CONFIG+=shared. Otherwise it fails to link.
+---
+ src/qmldevtools/qmldevtools.pro | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/qmldevtools/qmldevtools.pro b/src/qmldevtools/qmldevtools.pro
+index 23b7cf651..d48a36059 100644
+--- a/src/qmldevtools/qmldevtools.pro
++++ b/src/qmldevtools/qmldevtools.pro
+@@ -2,6 +2,8 @@ option(host_build)
+ TARGET = QtQmlDevTools
+ QT = core-private
+ CONFIG += minimal_syncqt internal_module qmldevtools_build
++CONFIG -= shared
++CONFIG += static staticlib
+
+ MODULE_INCNAME = QtQml
+ INCLUDEPATH += $$OUT_PWD/../qml
+--
+2.17.0
+
diff --git a/0002-Ensure-static-plugins-are-exported.patch b/0002-Ensure-static-plugins-are-exported.patch
index 519f1bcecb44..026f2c842e9f 100644
--- a/0002-Ensure-static-plugins-are-exported.patch
+++ b/0002-Ensure-static-plugins-are-exported.patch
@@ -1,4 +1,4 @@
-From 931571100b48c3c2d7cd797673f489531b0b45a2 Mon Sep 17 00:00:00 2001
+From e0a3f49cfd64490cc03c8d5e25555b06ce581a19 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 23 Oct 2016 01:18:13 +0200
Subject: [PATCH 2/3] Ensure static plugins are exported
@@ -18,5 +18,5 @@ index 9ddb9885c..9775d85e0 100644
foreach(_other_plugin ${_qt5qml_other_plugins})
include(${_other_plugin} OPTIONAL)
--
-2.16.1
+2.17.0
diff --git a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
index daa22d30ab62..c657f35296a9 100644
--- a/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
+++ b/0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch
@@ -1,4 +1,4 @@
-From 0cf5e799203f61ebdac79b68d7ab185aa506917b Mon Sep 17 00:00:00 2001
+From 327b82f8a5658eef45bf3bed0709e0566ab4f7f5 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 4 Feb 2017 01:59:59 +0100
Subject: [PATCH 3/3] Prevent exporting QML parser symbols on static build
@@ -33,5 +33,5 @@ index 0e195994b..8aa451e9d 100644
# define QML_PARSER_EXPORT
# elif defined(QT_BUILD_QML_LIB)
--
-2.16.1
+2.17.0
diff --git a/PKGBUILD b/PKGBUILD
index 818011be0f5a..a5a885bd68f1 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.10.1
+pkgver=5.11.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -24,13 +24,13 @@ license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Build-QML-dev-tools-as-shared-library.patch'
+ '0001-Ensure-QML-dev-tools-is-built-as-static-library.patch'
'0002-Ensure-static-plugins-are-exported.patch'
'0003-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-sha256sums=('3af9ed51bce5b5c6f04c4a67a6008f98765ccde897c43fff670621ab70789553'
- '777da4ec89376e654d9088ec70e3c5154dd8e31fa8de6f1f77f2d7d5f10bcd9b'
- 'e9afee84dfde3275807cc9b2eb1fb23b5074a12b8f896bd02d8b8f9963d545a6'
- 'cbf3675f3072bbab29fdf5541fd3c15986567a127f920cdaddcfff9e6a9d0283')
+sha256sums=('eea9378b17b1c16d3b5235629b9128349bf98cba7d9c61122653d976b25f57c0'
+ '95bf80aa39a9705d84d3cfe73b5de0540f2aa5853645f170d47cfa7ef8bd0074'
+ '182808bb60fcef2397e2e2476d1a86a43945f89cf653b58f2a6b6bf82e8cfe1e'
+ 'b629fa778ef275f07eb3cf224c0584813bd1825e005823307e0690ad4c8e1326')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -43,7 +43,7 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # Apply patches; further descriptions can be found in patch files itself
+ # apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
patch -p1 -i "$patch"
done
@@ -57,13 +57,14 @@ build() {
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
- # Search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
+ # search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
# hence we need insert those paths manually
make qmake_all
find ./src/qmldevtools -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-L$PWD/lib -L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib -L$PWD/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
- [ ${_config##*=} == 'shared' ] && local _ext='so' || local _ext='a'
+ #[ ${_config##*=} == 'shared' ] && local _ext='so' || local _ext='a'
+ local _ext='a'
find . -type f -iname 'Makefile' -exec sed -i "s|-L$PWD/lib -lQt5QmlDevTools|-L/usr/lib -L$PWD/lib ${srcdir}/${_pkgfqn}/build-${_arch}-${_config##*=}/lib/libQt5QmlDevTools.${_ext}|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5QmlDevTools|-L/usr/lib ${srcdir}/${_pkgfqn}/build-${_arch}-${_config##*=}/lib/libQt5QmlDevTools.${_ext}|g" {} \;
make
@@ -80,7 +81,7 @@ package() {
make INSTALL_ROOT="$pkgdir" install
- # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
pushd 'lib'
find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
@@ -92,25 +93,38 @@ package() {
popd
fi
- find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete || \
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
[[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ # strip native static libraries
+ find "${pkgdir}/usr/${_arch}" -name 'libQt5QmlDevTools.a' -exec strip -g {} \;
+
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
- # Make sure the executables don't conflict with their mingw-qt4 counterpart
- # Actually only qmlplugindump.exe conflicts, but for consistency all executables
- # will be suffixed.
+ # make sure the executables don't conflict with their mingw-qt4 counterpart
+ # (Actually only qmlplugindump.exe conflicts, but for consistency all executables
+ # will be suffixed.)
for _arch in ${_architectures}; do
for exe_file in "${pkgdir}/usr/${_arch}/bin/"*.exe; do
[[ -f $exe_file ]] && mv "${exe_file}" "${exe_file%.exe}-qt5.exe"