summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-05-28 21:54:50 +0200
committerMartchus2018-05-28 21:54:50 +0200
commit1011d8504df82ac1833072c4957d0af4b38f55db (patch)
tree92a30a0d061f5cde09678058bdc1ae7980d886ef
parent37c7973f9ec04635b09bf468fab88934626223fe (diff)
downloadaur-1011d8504df82ac1833072c4957d0af4b38f55db.tar.gz
Update to 5.11.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a50cae980983..c58268b5c4db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 19 19:15:18 UTC 2018
pkgbase = mingw-w64-qt5-gamepad
pkgdesc = Adds support for getting events from gamepad devices (mingw-w64)
- pkgver = 5.10.1
+ pkgver = 5.11.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -22,8 +20,8 @@ pkgbase = mingw-w64-qt5-gamepad
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtgamepad-everywhere-src-5.10.1.tar.xz
- sha256sums = 85c72801f56f7d5f55caff8ef23137978abe01637bb179566dd5976d6f5346f7
+ source = https://download.qt.io/official_releases/qt/5.11/5.11.0/submodules/qtgamepad-everywhere-src-5.11.0.tar.xz
+ sha256sums = 71a1445de3f0148639fcce27510f3eb410df6061bbb7af0f3ce5bff60660a23c
pkgname = mingw-w64-qt5-gamepad
diff --git a/PKGBUILD b/PKGBUILD
index 2da77771921a..f30e7afa1255 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_qt_module=qtgamepad
pkgname="mingw-w64-qt5-gamepad"
-pkgver=5.10.1
+pkgver=5.11.0
pkgrel=1
arch=('any')
pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('85c72801f56f7d5f55caff8ef23137978abe01637bb179566dd5976d6f5346f7')
+sha256sums=('71a1445de3f0148639fcce27510f3eb410df6061bbb7af0f3ce5bff60660a23c')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -54,7 +54,7 @@ package() {
make INSTALL_ROOT="$pkgdir" install
- # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
pushd 'lib'
find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
@@ -66,19 +66,29 @@ package() {
popd
fi
- find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete || \
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
[[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}