summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:23 +0100
committerMartchus2022-03-08 23:35:23 +0100
commit858151c4a176e49063241ffea723400d7a357e71 (patch)
tree44390fb05e84c79addfd21e1f138cd584f700625
parent0de6b67144670574faa0d5512138367f30559f2f (diff)
downloadaur-858151c4a176e49063241ffea723400d7a357e71.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2e23bb04fe8..f0b52c724d0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-gamepad
pkgdesc = Adds support for getting events from gamepad devices (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -12,14 +12,14 @@ pkgbase = mingw-w64-qt5-gamepad
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-qt5-declarative
+ makedepends = git
depends = mingw-w64-qt5-base
depends = mingw-w64-sdl2
optdepends = mingw-w64-qt5-declarative: QML bindings
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtgamepad-everywhere-src-5.15.2.tar.xz
- sha256sums = c77611f7898326d69176ad67a9b886f617cdedc368ec29f223d63537d25b075c
+ source = git+https://invent.kde.org/qt/qt/qtgamepad#commit=6b7a6303439f83147680723f4d8142d676cdb928
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-gamepad
-
diff --git a/PKGBUILD b/PKGBUILD
index 6d9763208e8f..e2de4ac4b73b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtgamepad
pkgname=mingw-w64-qt5-gamepad
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"
@@ -17,17 +17,30 @@ depends=('mingw-w64-qt5-base' 'mingw-w64-sdl2')
optdepends=('mingw-w64-qt5-declarative: QML bindings')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=6b7a6303439f83147680723f4d8142d676cdb928
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('c77611f7898326d69176ad67a9b886f617cdedc368ec29f223d63537d25b075c')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index ec55dde4015d..7317ff04efe7 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt5-module';
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"