summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:10:10 +0100
committerMartchus2020-01-29 19:10:10 +0100
commitc8e875d5ebb59a0a63bb2ebd9f04ccb8e96d91e5 (patch)
tree5cd3900d3b5b73497f0f56e25de94276da7307c3
parente3ebd4ce68c441ba79dee30fdd3e4dc519fef041 (diff)
downloadaur-c8e875d5ebb59a0a63bb2ebd9f04ccb8e96d91e5.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep10
-rw-r--r--qtgamepad-sha256.txt1
4 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f69f84b5e2ff..a140c80bc652 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-gamepad
pkgdesc = Adds support for getting events from gamepad devices (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -20,8 +20,8 @@ pkgbase = mingw-w64-qt5-gamepad
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtgamepad-everywhere-src-5.14.0.tar.xz
- sha256sums = 3d9835538afe7299e42d53a7bb85fb90aecdc714846671582139ff80d752a657
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtgamepad-everywhere-src-5.14.1.tar.xz
+ sha256sums = 13277d7362ebe912b55e233674bc862e4b5342705c9207bd16c83f107d0e3499
pkgname = mingw-w64-qt5-gamepad
diff --git a/PKGBUILD b/PKGBUILD
index ce9910214d68..48e8c860cdcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,36 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtgamepad
-pkgname="mingw-w64-qt5-gamepad"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-gamepad
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"
depends=('mingw-w64-qt5-base' 'mingw-w64-sdl2')
optdepends=('mingw-w64-qt5-declarative: QML bindings')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('3d9835538afe7299e42d53a7bb85fb90aecdc714846671582139ff80d752a657')
+sha256sums=('13277d7362ebe912b55e233674bc862e4b5342705c9207bd16c83f107d0e3499')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -38,7 +43,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..d7824cab2a39
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,10 @@
+% layout 'mingw-w64-qt5-module';
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"
+depends=('mingw-w64-qt5-base' 'mingw-w64-sdl2')
+optdepends=('mingw-w64-qt5-declarative: QML bindings')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtgamepad-sha256.txt b/qtgamepad-sha256.txt
new file mode 100644
index 000000000000..53820d390001
--- /dev/null
+++ b/qtgamepad-sha256.txt
@@ -0,0 +1 @@
+13277d7362ebe912b55e233674bc862e4b5342705c9207bd16c83f107d0e3499