summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:11 +0100
committerMartchus2022-03-08 23:35:11 +0100
commite26bf8afd7e3c823e1e2d40c24d821a561c5a8ba (patch)
treef0dc9b5f58c21731fbcabd25d999a6ed7224c2e4
parent14f869aa29a3d3d8619fb24ccd4cbea640706d9a (diff)
downloadaur-e26bf8afd7e3c823e1e2d40c24d821a561c5a8ba.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e67b2422e67..b424dce7f64d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-imageformats
pkgdesc = Plugins for additional image formats: TIFF, MNG, TGA, WBMP (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,12 @@ pkgbase = mingw-w64-qt5-imageformats
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtimageformats-everywhere-src-5.15.2.tar.xz
- sha256sums = bf8285c7ce04284527ab823ddc7cf48a1bb79131db3a7127342167f4814253d7
+ source = git+https://invent.kde.org/qt/qt/qtimageformats#commit=90038c936763645610fe1e5f05cfc025e4d98631
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-imageformats
-
diff --git a/PKGBUILD b/PKGBUILD
index 4c8550693102..239dd8361d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_qt_module=qtimageformats
pkgname=mingw-w64-qt5-imageformats
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Plugins for additional image formats: TIFF, MNG, TGA, WBMP (mingw-w64)"
@@ -22,17 +22,30 @@ depends=('mingw-w64-qt5-base')
#depends+=('mingw-w64-libwebp') # for WebP
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=90038c936763645610fe1e5f05cfc025e4d98631
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('bf8285c7ce04284527ab823ddc7cf48a1bb79131db3a7127342167f4814253d7')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index acbc4157e4d0..6179c7c7fa2e 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -5,7 +5,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Plugins for additional image formats: TIFF, MNG, TGA, WBMP (mingw-w64)"