summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-12-24 13:06:46 +0100
committerMartchus2016-12-24 13:06:46 +0100
commit25075862496929be68ad5ea739af44e3df93d601 (patch)
tree1940aec2c9d05f1189d568d6210fa9922b5312ef
parentd6489f26be3423102de7ec06252ad82cfa580816 (diff)
downloadaur-25075862496929be68ad5ea739af44e3df93d601.tar.gz
Update to 5.7.1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch26
-rw-r--r--PKGBUILD19
3 files changed, 48 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3eeeb07fbe5..bd6f6494e85c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 19:41:04 UTC 2016
+# Sat Dec 24 12:06:46 UTC 2016
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.7.0
- pkgrel = 3
+ pkgver = 5.7.1
+ pkgrel = 1
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
@@ -20,8 +20,10 @@ pkgbase = mingw-w64-qt5-location
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtlocation-opensource-src-5.7.0.tar.xz
- md5sums = 645477ff5426f5213f3581625ea53aaa
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.1/submodules/qtlocation-opensource-src-5.7.1.tar.xz
+ source = 0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
+ md5sums = e08b12addd6b9d995fdf059c5c9e04b3
+ md5sums = 97be1c13fddd5b68d1d3e532771b667e
pkgname = mingw-w64-qt5-location
diff --git a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
new file mode 100644
index 000000000000..fde81eca827b
--- /dev/null
+++ b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
@@ -0,0 +1,26 @@
+From b06f0c0bd0f125a9abf6f85d585445de0bdb396e Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 22 Dec 2016 22:30:59 +0100
+Subject: [PATCH] Ensure static 3rdparty libs are linked correctly
+
+---
+ src/imports/location/location.pro | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/imports/location/location.pro b/src/imports/location/location.pro
+index 57172ad8..ddea8b23 100644
+--- a/src/imports/location/location.pro
++++ b/src/imports/location/location.pro
+@@ -62,7 +62,8 @@ include(declarativeplaces/declarativeplaces.pri)
+
+ load(qml_plugin)
+
+-LIBS_PRIVATE += -L$$MODULE_BASE_OUTDIR/lib -lpoly2tri$$qtPlatformTargetSuffix() -lclip2tri$$qtPlatformTargetSuffix()
++LIBS_PRIVATE += -L$$MODULE_BASE_OUTDIR/lib -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
++QMAKE_LIBS_PRIVATE += -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
+
+ OTHER_FILES += \
+ plugin.json \
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 024a15f62d2b..917d8dad12b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.7.0
-pkgrel=3
+pkgver=5.7.1
+pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
@@ -20,8 +20,10 @@ groups=(mingw-w64-qt mingw-w64-qt5)
license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('645477ff5426f5213f3581625ea53aaa')
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
+md5sums=('e08b12addd6b9d995fdf059c5c9e04b3'
+ '97be1c13fddd5b68d1d3e532771b667e')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -31,6 +33,15 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=shared')
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"