summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-19 22:10:30 +0200
committerMartchus2016-08-19 22:10:30 +0200
commit3c6771cc002264bdbcd24440a8853b1514b4ef37 (patch)
treee4571621698286dd6df2d2a7111a75c5fbf529b1
parent1008f4dcbdea7ea28e317a5ddde21ed300c0ff51 (diff)
downloadaur-3c6771cc002264bdbcd24440a8853b1514b4ef37.tar.gz
Add static version of further Qt modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD50
2 files changed, 38 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31fb77d7c0a2..3c246653cca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:36:01 UTC 2016
+# Fri Aug 19 20:10:30 UTC 2016
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
pkgver = 5.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
@@ -11,8 +11,10 @@ pkgbase = mingw-w64-qt5-location
license = custom, FDL, GPL3, LGPL
makedepends = mingw-w64-gcc
makedepends = mingw-w64-qt5-quick1
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 5c8bc3979e08..0c4f4c0481c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
pkgver=5.7.0
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Provides access to position, satellite and area monitoring classes (mingw-w64)"
depends=(mingw-w64-qt5-base mingw-w64-qt5-declarative)
@@ -20,15 +23,25 @@ _pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
md5sums=('645477ff5426f5213f3581625ea53aaa')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=shared')
build() {
cd "${srcdir}/${_pkgfqn}"
+
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
- popd
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ make
+ popd
+ done
done
}
@@ -36,15 +49,20 @@ package() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
- pushd build-${_arch}
- make INSTALL_ROOT="${pkgdir}" install
-
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -o -name "*.bat" -o -name "*.def" -o -name "*.exp" -o -name '*.prl' | xargs -rtl1 rm
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
- popd
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
done
}