summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-11-21 16:55:18 +0100
committerMartchus2020-11-21 16:55:18 +0100
commit5bd9df0a2f951c89209617382f32b20e06c3f8a1 (patch)
tree866193a6bd1d9e106b5c62572ba007ee32ab46ec
parent4cd2e18fd5f33683a08e5dcc08b081de9c9698df (diff)
downloadaur-5bd9df0a2f951c89209617382f32b20e06c3f8a1.tar.gz
Update to 5.15.2
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch27
-rw-r--r--PKGBUILD19
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtlocation-sha256.txt2
5 files changed, 8 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f58442d4f92c..403fe8ed8f5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.15.1
+ pkgver = 5.15.2
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -16,10 +16,8 @@ pkgbase = mingw-w64-qt5-location
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtlocation-everywhere-src-5.15.1.tar.xz
- source = 0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
- sha256sums = 093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c
- sha256sums = 0f20c005812f031cfb70ac83f370a894819847c6e4447b2229bc50c1708dd2d0
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtlocation-everywhere-src-5.15.2.tar.xz
+ sha256sums = 984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0
pkgname = mingw-w64-qt5-location
diff --git a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
deleted file mode 100644
index 4c019f3f3d7d..000000000000
--- a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 7e32a0fe5a2c08e1a4e5d14e8d34139ccbd908c9 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Thu, 22 Dec 2016 22:30:59 +0100
-Subject: [PATCH] Ensure static 3rdparty libs are linked correctly
-
-Not sure whether this is still required in Qt 5.9.0
----
- src/imports/location/location.pro | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/imports/location/location.pro b/src/imports/location/location.pro
-index 40605806..fa82a012 100644
---- a/src/imports/location/location.pro
-+++ b/src/imports/location/location.pro
-@@ -5,6 +5,9 @@ SOURCES += \
-
- load(qml_plugin)
-
-+LIBS_PRIVATE += -L$$MODULE_BASE_OUTDIR/lib -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
-+QMAKE_LIBS_PRIVATE += -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
-+
- OTHER_FILES += \
- plugin.json \
- qmldir
---
-2.28.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f644443d5fb..a4f426864e40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,6 @@
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
-# All patches are managed at https://github.com/Martchus/qtlocation
-
# Skip building mapbox and mapboxgl; that decreases the compile time significantly and
# likely not a lot of people actually using it; if you need it, just remove the corresponding
# qmake flags:
@@ -17,7 +15,7 @@ _additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservic
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.15.1
+pkgver=5.15.2
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
@@ -28,24 +26,13 @@ options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
-sha256sums=('093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c'
- '0f20c005812f031cfb70ac83f370a894819847c6e4447b2229bc50c1708dd2d0')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
-prepare() {
- cd "${srcdir}/${_pkgfqn}"
-
- # apply patches; further descriptions can be found in patch files itself
- for patch in "$srcdir/"*.patch; do
- patch -p1 -i "$patch"
- done
-}
-
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index f00fb09ce0ce..9115a31de2ee 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -12,7 +12,7 @@ _additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservic
% end
\
-pkgver=5.15.1
+pkgver=5.15.2
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
diff --git a/qtlocation-sha256.txt b/qtlocation-sha256.txt
index 40c9289e8911..d4c17d7692af 100644
--- a/qtlocation-sha256.txt
+++ b/qtlocation-sha256.txt
@@ -1 +1 @@
-093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c
+984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0