summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:05 +0100
committerMartchus2022-03-08 23:35:05 +0100
commit6295165fdab846f619d50f4d02bbdbbdbe12c204 (patch)
tree9554b6c3210f2c1ae4bb0713adb4d000e7e54202
parent5bd9df0a2f951c89209617382f32b20e06c3f8a1 (diff)
downloadaur-6295165fdab846f619d50f4d02bbdbbdbe12c204.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 403fe8ed8f5e..3d3a60e5b5e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,13 +11,13 @@ pkgbase = mingw-w64-qt5-location
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtlocation-everywhere-src-5.15.2.tar.xz
- sha256sums = 984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0
+ source = git+https://invent.kde.org/qt/qt/qtlocation#commit=1bf01b84e30aab2b87a19184ce42160e6c92d8b1
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-location
-
diff --git a/PKGBUILD b/PKGBUILD
index a4f426864e40..d6c1426bdce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,24 +15,37 @@ _additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservic
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=1bf01b84e30aab2b87a19184ce42160e6c92d8b1
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 9115a31de2ee..d1974965a526 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -12,7 +12,7 @@ _additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservic
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'