summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:17 +0100
committerMartchus2020-01-29 19:09:17 +0100
commitd64aba7f74a4c90a10c54c31acd2986882c39203 (patch)
tree890ff088b1ac33b780785f35b5f69478475941a0
parentaf2ac972bd22b9c23633f798f1efe255f8aa5537 (diff)
downloadaur-d64aba7f74a4c90a10c54c31acd2986882c39203.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch4
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep21
-rw-r--r--qtlocation-sha256.txt1
5 files changed, 42 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eaca1a405c6..4558784de3ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -18,10 +18,10 @@ pkgbase = mingw-w64-qt5-location
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtlocation-everywhere-src-5.14.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtlocation-everywhere-src-5.14.1.tar.xz
source = 0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
- sha256sums = 87906fd100dd93ed495a4db2c435dcfab073d399ea11d5e18727cc782fac4cd1
- sha256sums = aa8551a7c6721ac98ebe2b3231cdf1d9d78fc0181409a31c9dd1d038afca50f6
+ sha256sums = a0dd1712a5b7a0425b57d17318294b6f7e968c4b81d52048696d029b04d2f12f
+ sha256sums = 5180fad65717eca47134e8019ada8f8f5e755df59c854568af35d0d5395d11b0
pkgname = mingw-w64-qt5-location
diff --git a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
index bef9ca81d19a..cbe90c57c701 100644
--- a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
+++ b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
@@ -1,4 +1,4 @@
-From 2a7e4a9cdb88f7f9df23fcd4fd190e0faf301725 Mon Sep 17 00:00:00 2001
+From 0fd1be73c7360f39bf373507e8aabe12a99aba26 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 22 Dec 2016 22:30:59 +0100
Subject: [PATCH] Ensure static 3rdparty libs are linked correctly
@@ -23,5 +23,5 @@ index 40605806..fa82a012 100644
plugin.json \
qmldir
--
-2.24.1
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index 82ad308c4c05..7f2483146cf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,37 +4,44 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtlocation
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
# Skip building mapboxgl as it increases compile time significantly and
# likely not a lot of people actually using it; if you need it, just remove the
# following line:
-_mapboxcfg='QT.global.disabled_features+=geoservices_mapboxgl'
+_additional_qmake_args+='QT.global.disabled_features+=geoservices_mapboxgl'
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.14.0
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
-sha256sums=('87906fd100dd93ed495a4db2c435dcfab073d399ea11d5e18727cc782fac4cd1'
- 'aa8551a7c6721ac98ebe2b3231cdf1d9d78fc0181409a31c9dd1d038afca50f6')
+sha256sums=('a0dd1712a5b7a0425b57d17318294b6f7e968c4b81d52048696d029b04d2f12f'
+ '5180fad65717eca47134e8019ada8f8f5e755df59c854568af35d0d5395d11b0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -54,7 +61,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_mapboxcfg}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..e929358a005b
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,21 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+% end
+\
+% content_for comment_header => begin
+# Skip building mapboxgl as it increases compile time significantly and
+# likely not a lot of people actually using it; if you need it, just remove the
+# following line:
+_additional_qmake_args+='QT.global.disabled_features+=geoservices_mapboxgl'
+
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
+depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtlocation-sha256.txt b/qtlocation-sha256.txt
new file mode 100644
index 000000000000..d181d816f410
--- /dev/null
+++ b/qtlocation-sha256.txt
@@ -0,0 +1 @@
+a0dd1712a5b7a0425b57d17318294b6f7e968c4b81d52048696d029b04d2f12f