summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:13 +0100
committerMartchus2018-02-19 20:15:13 +0100
commite9d566d876f717b69e5fd36e98eb43628c71afde (patch)
treef3ca1df81e3ff2bc928e0a0fc530aee618e5bd55
parente8a67d2b79248bae17d96e6c8d5cbe085931484c (diff)
downloadaur-e9d566d876f717b69e5fd36e98eb43628c71afde.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch4
-rw-r--r--PKGBUILD22
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d94873eb5747..8fc6b690b86a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:23 UTC 2017
+# Mon Feb 19 19:15:13 UTC 2018
pkgbase = mingw-w64-qt5-location
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -20,10 +20,10 @@ pkgbase = mingw-w64-qt5-location
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtlocation-everywhere-src-5.10.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtlocation-everywhere-src-5.10.1.tar.xz
source = 0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
- sha256sums = d84dcec7cfbc99a13e048f935783b0c2e1cb540defc82d77ac869a5b76aa85c7
- sha256sums = a4380c11444f11f79f5c78d76121e45aa27add611bc53204bb867fdf0832888c
+ sha256sums = 5e5cc05517c701a2c8ebba1fbe3ddff2b6b90d5aa554d307b1c477fe0cfd72c9
+ sha256sums = fe196a9d212be5d383a41a385e4801336a58e9c57a731be7438482d5b71b3bae
pkgname = mingw-w64-qt5-location
diff --git a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
index 6ef34ea6e827..6d2fcc9d44c2 100644
--- a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
+++ b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
@@ -1,4 +1,4 @@
-From 3912c09ab1d9fc9659765fd7db3fe7161e203320 Mon Sep 17 00:00:00 2001
+From c9dbef4fbfebc8de186925cdda9f343eef287d7f Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 22 Dec 2016 22:30:59 +0100
Subject: [PATCH] Ensure static 3rdparty libs are linked correctly
@@ -23,5 +23,5 @@ index dec1149b..ad57a5c5 100644
plugin.json \
qmldir
--
-2.15.1
+2.16.1
diff --git a/PKGBUILD b/PKGBUILD
index f7ffa03f5c17..e8df4eb3a8cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ _mapboxcfg='QT.global.disabled_features+=geoservices_mapboxgl'
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
@@ -27,8 +27,8 @@ url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
-sha256sums=('d84dcec7cfbc99a13e048f935783b0c2e1cb540defc82d77ac869a5b76aa85c7'
- 'a4380c11444f11f79f5c78d76121e45aa27add611bc53204bb867fdf0832888c')
+sha256sums=('5e5cc05517c701a2c8ebba1fbe3ddff2b6b90d5aa554d307b1c477fe0cfd72c9'
+ 'fe196a9d212be5d383a41a385e4801336a58e9c57a731be7438482d5b71b3bae')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -69,6 +69,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
@@ -80,5 +93,8 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}