summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:06 +0100
committerMartchus2022-03-08 23:35:06 +0100
commit98834ecb007a9811a3e31f998cb820efb8699cbf (patch)
tree4d6df6c605fc9fa30e2be9a7abbbf4bafc6cbb6d
parent7661708370810a403e3bef700ebe0b94ac234d2c (diff)
downloadaur-98834ecb007a9811a3e31f998cb820efb8699cbf.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ac8fce806d5..97479a9f5159 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-location-static
pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,14 +11,14 @@ pkgbase = mingw-w64-qt5-location-static
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative-static
depends = mingw-w64-qt5-location
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtlocation-everywhere-src-5.15.2.tar.xz
- sha256sums = 984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0
+ source = git+https://invent.kde.org/qt/qt/qtlocation#commit=1bf01b84e30aab2b87a19184ce42160e6c92d8b1
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-location-static
-
diff --git a/PKGBUILD b/PKGBUILD
index e2241bb4465c..50ad7a23e5e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,25 +15,38 @@ _additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservic
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=1bf01b84e30aab2b87a19184ce42160e6c92d8b1
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('984fcb09e108df49a8dac35d5ce6dffc49caafd2acb1c2f8a5173a6a21f392a0')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"