summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:40 +0200
committerMartchus2020-09-13 13:26:40 +0200
commitfe82a7f1cfea71ec2d60c0a4d2f788841b198a37 (patch)
tree24eb2e7b17191fb934e3ea3725a53b67ef45dfdb
downloadaur-fe82a7f1cfea71ec2d60c0a4d2f788841b198a37.tar.gz
Update to 5.15.1
-rw-r--r--.SRCINFO26
-rw-r--r--0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch27
-rw-r--r--PKGBUILD120
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtlocation-sha256.txt1
5 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb404f5078d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mingw-w64-qt5-location-static
+ pkgdesc = Provides access to position, satellite and area monitoring classes (mingw-w64)
+ pkgver = 5.15.1
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = any
+ groups = mingw-w64-qt5
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-qt5-base-static
+ depends = mingw-w64-qt5-declarative-static
+ depends = mingw-w64-qt5-location
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtlocation-everywhere-src-5.15.1.tar.xz
+ source = 0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
+ sha256sums = 093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c
+ sha256sums = 0f20c005812f031cfb70ac83f370a894819847c6e4447b2229bc50c1708dd2d0
+
+pkgname = mingw-w64-qt5-location-static
+
diff --git a/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
new file mode 100644
index 000000000000..4c019f3f3d7d
--- /dev/null
+++ b/0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch
@@ -0,0 +1,27 @@
+From 7e32a0fe5a2c08e1a4e5d14e8d34139ccbd908c9 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 22 Dec 2016 22:30:59 +0100
+Subject: [PATCH] Ensure static 3rdparty libs are linked correctly
+
+Not sure whether this is still required in Qt 5.9.0
+---
+ src/imports/location/location.pro | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/imports/location/location.pro b/src/imports/location/location.pro
+index 40605806..fa82a012 100644
+--- a/src/imports/location/location.pro
++++ b/src/imports/location/location.pro
+@@ -5,6 +5,9 @@ SOURCES += \
+
+ load(qml_plugin)
+
++LIBS_PRIVATE += -L$$MODULE_BASE_OUTDIR/lib -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
++QMAKE_LIBS_PRIVATE += -lclip2tri$$qtPlatformTargetSuffix() -lclipper$$qtPlatformTargetSuffix() -lpoly2tri$$qtPlatformTargetSuffix()
++
+ OTHER_FILES += \
+ plugin.json \
+ qmldir
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d93aa0f7d6b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,120 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtlocation
+
+# Skip building mapbox and mapboxgl; that decreases the compile time significantly and
+# likely not a lot of people actually using it; if you need it, just remove the corresponding
+# qmake flags:
+_additional_qmake_args+='-- -no-feature-geoservices_mapbox -no-feature-geoservices_mapboxgl'
+
+_qt_module=qtlocation
+pkgname=mingw-w64-qt5-location-static
+pkgver=5.15.1
+pkgrel=1
+arch=('any')
+pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
+depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+url='https://www.qt.io/'
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
+sha256sums=('093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c'
+ '0f20c005812f031cfb70ac83f370a894819847c6e4447b2229bc50c1708dd2d0')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
+_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
+ make
+ popd
+ done
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
+ # delete duplicate files that are in the shared package
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ for shared_path in "${pkgdir}/usr/${_arch}/"{include,share} "${pkgdir}/usr/${_arch}/lib/"{qt/bin,qt/mkspecs}; do
+ [[ -d $shared_path ]] && rm -fR "$shared_path"
+ done
+ for file in $(find "$pkgdir/usr/$_arch/lib"); do
+ [[ -f "${file##$pkgdir}" ]] && rm "$file"
+ done
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
+
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+ done
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtlocation-sha256.txt b/qtlocation-sha256.txt
new file mode 100644
index 000000000000..40c9289e8911
--- /dev/null
+++ b/qtlocation-sha256.txt
@@ -0,0 +1 @@
+093af763a70d126c4b9f6a22ebf8218fe95dc0151e40666b2389fdf55c9f1a2c