summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-28 19:40:38 +0200
committerMartchus2016-03-28 19:40:38 +0200
commit8568826d2ecf0e873f47bccd3a7edf9968e969ed (patch)
treebfec6712acca45e0cfee319b38bea0966542115f
parent4d9bc9936c949217ee02f729142de67d396f3b3c (diff)
downloadaur-8568826d2ecf0e873f47bccd3a7edf9968e969ed.tar.gz
updated to 5.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
-rw-r--r--qtmultimedia-dont-use-case-sensitive-headers.patch22
3 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54cbeb17ee5f..85c9edbcd314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 22:50:56 UTC 2016
+# Mon Mar 28 17:31:58 UTC 2016
pkgbase = mingw-w64-qt5-multimedia
pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
- pkgver = 5.5.1
+ pkgver = 5.6.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -15,12 +15,10 @@ pkgbase = mingw-w64-qt5-multimedia
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qtmultimedia-opensource-src-5.5.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qtmultimedia-opensource-src-5.6.0.tar.xz
source = qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch
- source = qtmultimedia-dont-use-case-sensitive-headers.patch
- md5sums = 244baff13a02ebc697e5b5e2290088d0
+ md5sums = c66e500f6d5be693231718cccf997c30
md5sums = c21ff895212a17dc0a748aeadb67601d
- md5sums = 7ecd5ee2735440472fae4b7d7a32879e
pkgname = mingw-w64-qt5-multimedia
diff --git a/PKGBUILD b/PKGBUILD
index f1095f3836d0..14963feb189c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,11 @@
# Maintainer: Martchus <martchus@gmx.net>
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia
-pkgver=5.5.1
+pkgver=5.6.0
pkgrel=1
arch=(any)
pkgdesc="Classes for audio, video, radio and camera functionality (mingw-w64)"
@@ -14,14 +17,18 @@ license=("custom, FDL, GPL3, LGPL")
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch"
- "qtmultimedia-dont-use-case-sensitive-headers.patch")
-md5sums=('244baff13a02ebc697e5b5e2290088d0'
- 'c21ff895212a17dc0a748aeadb67601d'
- '7ecd5ee2735440472fae4b7d7a32879e')
+ "qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch")
+md5sums=('c66e500f6d5be693231718cccf997c30'
+ 'c21ff895212a17dc0a748aeadb67601d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+link_header_files() {
+ for header in "$@"; do
+ ln -s "/usr/${_arch}/include/${header,,}" "./sysinclude/${header}"
+ done
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
# Some files #include <dshow.h>
@@ -29,16 +36,18 @@ prepare() {
# This #define vsnprint conflicts with QtCore/qstring.h so reorder the includes
# a bit to prevent this situation
patch -p0 -i ../qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch
-
- # MinGW headers are case sensitive under Linux
- patch -p1 -i ../qtmultimedia-dont-use-case-sensitive-headers.patch
}
build() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro -Wall
+
+ # headers are case sensitive under Linux -> provide symlinks
+ mkdir -p ./sysinclude/qtgui && link_header_files {ShlObj,Evr9,Mferror}.h
+ ln -s "/usr/${_arch}/include/qt/QtGui/qguiapplication.h" "./sysinclude/qtgui/qguiapplication.h"
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro -Wall INCLUDEPATH+="${srcdir}/${_pkgfqn}/build-${_arch}/sysinclude"
make
popd
done
diff --git a/qtmultimedia-dont-use-case-sensitive-headers.patch b/qtmultimedia-dont-use-case-sensitive-headers.patch
deleted file mode 100644
index 06cbb3799c22..000000000000
--- a/qtmultimedia-dont-use-case-sensitive-headers.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- qtmultimedia-opensource-src-5.2.0-rc1/config.tests/wshellitem/main.cpp.orig 2013-11-21 11:29:48.845013461 +0100
-+++ qtmultimedia-opensource-src-5.2.0-rc1/config.tests/wshellitem/main.cpp 2013-11-21 11:29:55.980132333 +0100
-@@ -39,7 +39,7 @@
- **
- ****************************************************************************/
-
--#include <ShlObj.h>
-+#include <shlobj.h>
-
- int main(int, char**)
- {
---- qtmultimedia-opensource-src-5.2.0-rc1/src/plugins/directshow/player/directshowmetadatacontrol.cpp.orig 2013-11-21 11:34:00.866215162 +0100
-+++ qtmultimedia-opensource-src-5.2.0-rc1/src/plugins/directshow/player/directshowmetadatacontrol.cpp 2013-11-21 11:34:11.361390182 +0100
-@@ -57,7 +57,7 @@
- #endif
-
- #ifndef QT_NO_SHELLITEM
--#include <ShlObj.h>
-+#include <shlobj.h>
- #include <propkeydef.h>
- #include <private/qsystemlibrary_p.h>
-