summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-12-08 20:41:07 +0100
committerMartchus2016-12-08 20:41:07 +0100
commit8b72c73b05a55588e957c7f67e5f387c59d507f3 (patch)
tree9a3c9e4f4c15e67a4d834d216c6c57cf4696e794
parentcc4c8045a8985085987e3823b91c35bc721aa6a2 (diff)
downloadaur-8b72c73b05a55588e957c7f67e5f387c59d507f3.tar.gz
Fix misc issues
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch54
-rw-r--r--0002-Fix-build-with-ANGLE.patch29
-rw-r--r--PKGBUILD30
4 files changed, 110 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f1cd84c2d84..d3da25919d96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 20:10:30 UTC 2016
+# Thu Dec 8 19:41:06 UTC 2016
pkgbase = mingw-w64-qt5-multimedia
pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
pkgver = 5.7.0
- pkgrel = 2
+ pkgrel = 4
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
groups = mingw-w64-qt5
- license = custom, FDL, GPL3, LGPL
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
@@ -18,9 +21,11 @@ pkgbase = mingw-w64-qt5-multimedia
options = !buildflags
options = staticlibs
source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtmultimedia-opensource-src-5.7.0.tar.xz
- source = qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch
+ source = 0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
+ source = 0002-Fix-build-with-ANGLE.patch
md5sums = 44c1b9a1dfb0e8b13f2d9571829500ee
- md5sums = c21ff895212a17dc0a748aeadb67601d
+ md5sums = 7fcbd5f8d487921448290fe2c20f5c64
+ md5sums = a4fc0aecda3de244960fa41675cdda0d
pkgname = mingw-w64-qt5-multimedia
diff --git a/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
new file mode 100644
index 000000000000..96c285b62c36
--- /dev/null
+++ b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
@@ -0,0 +1,54 @@
+From db2f1776934938b3547551e8fb28844fc91fcab9 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:36:56 +0200
+Subject: [PATCH 1/2] Recorder includes to prevent conflict with vsnprintf
+
+Some files #include <dshow.h>
+This is a C header which also #include's stdio.h which adds a #define vsnprintf
+This #define vsnprint conflicts with QtCore/qstring.h so reorder the includes
+a bit to prevent this situation
+---
+ src/multimedia/video/qvideosurfaceformat.h | 1 +
+ src/plugins/directshow/player/directshowglobal.h | 1 +
+ src/plugins/directshow/player/directshowmediatypelist.h | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/src/multimedia/video/qvideosurfaceformat.h b/src/multimedia/video/qvideosurfaceformat.h
+index 83785ac..25607d0 100644
+--- a/src/multimedia/video/qvideosurfaceformat.h
++++ b/src/multimedia/video/qvideosurfaceformat.h
+@@ -44,6 +44,7 @@
+ #include <QtCore/qpair.h>
+ #include <QtCore/qshareddata.h>
+ #include <QtCore/qsize.h>
++#include <QtCore/qstring.h>
+ #include <QtGui/qimage.h>
+ #include <QtMultimedia/qvideoframe.h>
+
+diff --git a/src/plugins/directshow/player/directshowglobal.h b/src/plugins/directshow/player/directshowglobal.h
+index f7890c5..4f7c821 100644
+--- a/src/plugins/directshow/player/directshowglobal.h
++++ b/src/plugins/directshow/player/directshowglobal.h
+@@ -43,6 +43,7 @@
+ #include <dshow.h>
+
+ #include <QtCore/qglobal.h>
++#include <QtCore/qstring.h>
+
+ template <typename T> T *com_cast(IUnknown *unknown, const IID &iid)
+ {
+diff --git a/src/plugins/directshow/player/directshowmediatypelist.h b/src/plugins/directshow/player/directshowmediatypelist.h
+index c6dac0e..ad81b3d 100644
+--- a/src/plugins/directshow/player/directshowmediatypelist.h
++++ b/src/plugins/directshow/player/directshowmediatypelist.h
+@@ -43,6 +43,7 @@
+ #include <dshow.h>
+
+ #include <QtCore/qvector.h>
++#include <QtCore/qstring.h>
+
+ class DirectShowMediaTypeList : public IUnknown
+ {
+--
+2.10.2
+
diff --git a/0002-Fix-build-with-ANGLE.patch b/0002-Fix-build-with-ANGLE.patch
new file mode 100644
index 000000000000..3729856f40fa
--- /dev/null
+++ b/0002-Fix-build-with-ANGLE.patch
@@ -0,0 +1,29 @@
+From 7a2483830b6aa6744ea6eb661fab59d76ff32d9d Mon Sep 17 00:00:00 2001
+From: Jose Santiago <jsantiago@haivision.com>
+Date: Thu, 3 Nov 2016 14:36:10 -0500
+Subject: [PATCH 2/2] Fix build with ANGLE
+
+---
+ src/plugins/common/evr/evrd3dpresentengine.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/plugins/common/evr/evrd3dpresentengine.cpp b/src/plugins/common/evr/evrd3dpresentengine.cpp
+index 9718c78..5bd8d81 100644
+--- a/src/plugins/common/evr/evrd3dpresentengine.cpp
++++ b/src/plugins/common/evr/evrd3dpresentengine.cpp
+@@ -49,9 +49,9 @@
+ #include <private/qmediaopenglhelper_p.h>
+
+ #ifdef MAYBE_ANGLE
+-# include <qtgui/qguiapplication.h>
+-# include <qpa/qplatformnativeinterface.h>
+-# include <qopenglfunctions.h>
++# include <QtGui/qguiapplication.h>
++# include <QtGui/qpa/qplatformnativeinterface.h>
++# include <QtGui/qopenglfunctions.h>
+ # include <EGL/eglext.h>
+ #endif
+
+--
+2.10.2
+
diff --git a/PKGBUILD b/PKGBUILD
index a13b7f05bd89..02efd05fc9f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,27 @@
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+# All patches are managed at https://github.com/Martchus/qtmultimedia
+
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia
pkgver=5.7.0
-pkgrel=2
+pkgrel=4
arch=('any')
-pkgdesc="Classes for audio, video, radio and camera functionality (mingw-w64)"
-depends=(mingw-w64-qt5-base mingw-w64-qt5-declarative)
-makedepends=(mingw-w64-gcc)
+pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
+depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc')
options=(!strip !buildflags staticlibs)
groups=(mingw-w64-qt mingw-w64-qt5)
-license=("custom, FDL, GPL3, LGPL")
-url="https://www.qt.io/"
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch")
+ '0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch'
+ '0002-Fix-build-with-ANGLE.patch')
md5sums=('44c1b9a1dfb0e8b13f2d9571829500ee'
- 'c21ff895212a17dc0a748aeadb67601d')
+ '7fcbd5f8d487921448290fe2c20f5c64'
+ 'a4fc0aecda3de244960fa41675cdda0d')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -40,11 +44,11 @@ link_header_files() {
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # Some files #include <dshow.h>
- # This is a C header which also #include's stdio.h which adds a #define vsnprintf
- # This #define vsnprint conflicts with QtCore/qstring.h so reorder the includes
- # a bit to prevent this situation
- patch -p0 -i ../qt5-qtmultimedia-mingw-w64-vsnprintf-workaround.patch
+
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
}
build() {