summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-02-09 21:00:42 +0100
committerMartchus2017-02-09 21:00:42 +0100
commit91fb829eecefd3a4a6be3dce022e9cba6bec5db2 (patch)
tree859415d36d15b648a69c56de5c6f5362c9555dcd
parent1e39ec4e5af46da7a40fc887c2681803afec9f2f (diff)
downloadaur-91fb829eecefd3a4a6be3dce022e9cba6bec5db2.tar.gz
Update to 5.8.0
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch27
-rw-r--r--0002-Fix-build-with-ANGLE.patch2
-rw-r--r--PKGBUILD14
4 files changed, 22 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c087a283d3a9..db842e14bb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Sat Dec 24 12:06:46 UTC 2016
+# Thu Feb 9 20:00:41 UTC 2017
pkgbase = mingw-w64-qt5-multimedia
pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
- pkgver = 5.7.1
+ pkgver = 5.8.0
pkgrel = 1
url = https://www.qt.io/
arch = any
- groups = mingw-w64-qt
groups = mingw-w64-qt5
license = GPL3
license = LGPL
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
@@ -20,12 +20,12 @@ pkgbase = mingw-w64-qt5-multimedia
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.7/5.7.1/submodules/qtmultimedia-opensource-src-5.7.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.8/5.8.0/submodules/qtmultimedia-opensource-src-5.8.0.tar.xz
source = 0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
source = 0002-Fix-build-with-ANGLE.patch
- md5sums = 2b384ea22ae1dd7cec9ee40501ab2b45
- md5sums = d6b316ff6e782fe21d4b8ecf32e4d9ac
- md5sums = eac5d4f48704c07a906ae8e129659820
+ md5sums = c8610023cfe036d3ad7c13f6e99892cf
+ md5sums = cb0cb6bc9e82d052fe9d973019c99d9b
+ md5sums = 27c71ce264710693d99e1e12ba82c106
pkgname = mingw-w64-qt5-multimedia
diff --git a/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
index a59e67e066a2..22dae55f31fb 100644
--- a/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
+++ b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
@@ -1,4 +1,4 @@
-From 3482b1b61375265b7c3fa065bdc0da1fe5d76a0e Mon Sep 17 00:00:00 2001
+From ecfcbb10eaae22d0887e074e3734d6d9e69d2e34 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:36:56 +0200
Subject: [PATCH 1/2] Recorder includes to prevent conflict with vsnprintf
@@ -8,10 +8,9 @@ This is a C header which also #include's stdio.h which adds a #define vsnprintf
This #define vsnprint conflicts with QtCore/qstring.h so reorder the includes
a bit to prevent this situation
---
- src/multimedia/video/qvideosurfaceformat.h | 1 +
- src/plugins/directshow/player/directshowglobal.h | 1 +
- src/plugins/directshow/player/directshowmediatypelist.h | 1 +
- 3 files changed, 3 insertions(+)
+ src/multimedia/video/qvideosurfaceformat.h | 1 +
+ src/plugins/directshow/helpers/directshowglobal.h | 1 +
+ 2 files changed, 2 insertions(+)
diff --git a/src/multimedia/video/qvideosurfaceformat.h b/src/multimedia/video/qvideosurfaceformat.h
index 83785ac0..25607d08 100644
@@ -25,10 +24,10 @@ index 83785ac0..25607d08 100644
#include <QtGui/qimage.h>
#include <QtMultimedia/qvideoframe.h>
-diff --git a/src/plugins/directshow/player/directshowglobal.h b/src/plugins/directshow/player/directshowglobal.h
+diff --git a/src/plugins/directshow/helpers/directshowglobal.h b/src/plugins/directshow/helpers/directshowglobal.h
index f7890c52..4f7c8213 100644
---- a/src/plugins/directshow/player/directshowglobal.h
-+++ b/src/plugins/directshow/player/directshowglobal.h
+--- a/src/plugins/directshow/helpers/directshowglobal.h
++++ b/src/plugins/directshow/helpers/directshowglobal.h
@@ -43,6 +43,7 @@
#include <dshow.h>
@@ -37,18 +36,6 @@ index f7890c52..4f7c8213 100644
template <typename T> T *com_cast(IUnknown *unknown, const IID &iid)
{
-diff --git a/src/plugins/directshow/player/directshowmediatypelist.h b/src/plugins/directshow/player/directshowmediatypelist.h
-index 2bd8dca5..7b8e572c 100644
---- a/src/plugins/directshow/player/directshowmediatypelist.h
-+++ b/src/plugins/directshow/player/directshowmediatypelist.h
-@@ -43,6 +43,7 @@
- #include <dshow.h>
-
- #include <QtCore/qvector.h>
-+#include <QtCore/qstring.h>
-
- class DirectShowMediaTypeList : public IUnknown
- {
--
2.11.0
diff --git a/0002-Fix-build-with-ANGLE.patch b/0002-Fix-build-with-ANGLE.patch
index c14617e0bf51..5dd599ffe6c6 100644
--- a/0002-Fix-build-with-ANGLE.patch
+++ b/0002-Fix-build-with-ANGLE.patch
@@ -1,4 +1,4 @@
-From b32771b178c106167dfa71ae3e2ac53e1845a3c2 Mon Sep 17 00:00:00 2001
+From 17ca839c5b370748fc55e64f826d39ab25eee13e Mon Sep 17 00:00:00 2001
From: Jose Santiago <jsantiago@haivision.com>
Date: Thu, 3 Nov 2016 14:36:10 -0500
Subject: [PATCH 2/2] Fix build with ANGLE
diff --git a/PKGBUILD b/PKGBUILD
index 540af150958e..67aafad1cfdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,23 +10,23 @@
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia
-pkgver=5.7.1
+pkgver=5.8.0
pkgrel=1
arch=('any')
pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
-makedepends=('mingw-w64-gcc')
-options=(!strip !buildflags staticlibs)
-groups=(mingw-w64-qt mingw-w64-qt5)
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch'
'0002-Fix-build-with-ANGLE.patch')
-md5sums=('2b384ea22ae1dd7cec9ee40501ab2b45'
- 'd6b316ff6e782fe21d4b8ecf32e4d9ac'
- 'eac5d4f48704c07a906ae8e129659820')
+md5sums=('c8610023cfe036d3ad7c13f6e99892cf'
+ 'cb0cb6bc9e82d052fe9d973019c99d9b'
+ '27c71ce264710693d99e1e12ba82c106')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \