summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-19 22:10:31 +0200
committerMartchus2016-08-19 22:10:31 +0200
commitcc4c8045a8985085987e3823b91c35bc721aa6a2 (patch)
treee4bafd6f492d7b1521df026d4d413f51dc5589aa
parent2a0b5e4ff803e08d2e0a79a24dcbc454460ddef5 (diff)
downloadaur-cc4c8045a8985085987e3823b91c35bc721aa6a2.tar.gz
Add static version of further Qt modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD58
2 files changed, 42 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae6a14f8ed0c..8f1cd84c2d84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:36:02 UTC 2016
+# Fri Aug 19 20:10:30 UTC 2016
pkgbase = mingw-w64-qt5-multimedia
pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
pkgver = 5.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
groups = mingw-w64-qt5
license = custom, FDL, GPL3, LGPL
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index fb401769c7d8..a13b7f05bd89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia
pkgver=5.7.0
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Classes for audio, video, radio and camera functionality (mingw-w64)"
depends=(mingw-w64-qt5-base mingw-w64-qt5-declarative)
@@ -21,7 +24,13 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
md5sums=('44c1b9a1dfb0e8b13f2d9571829500ee'
'c21ff895212a17dc0a748aeadb67601d')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=shared')
link_header_files() {
for header in "$@"; do
@@ -40,30 +49,39 @@ prepare() {
build() {
cd "${srcdir}/${_pkgfqn}"
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
-
- # headers are case sensitive under Linux -> provide symlinks
- mkdir -p ./sysinclude/qtgui && link_header_files {ShlObj,Evr9,Mferror}.h
- ln -s "/usr/${_arch}/include/qt/QtGui/qguiapplication.h" "./sysinclude/qtgui/qguiapplication.h"
- ${_arch}-qmake-qt5 ../${_qt_module}.pro -Wall INCLUDEPATH+="${srcdir}/${_pkgfqn}/build-${_arch}/sysinclude"
- make
- popd
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ # Header are case sensitive under Linux, provide symlinks to prevent compile errors
+ mkdir -p ./sysinclude/qtgui && link_header_files {ShlObj,Evr9,Mferror}.h
+ ln -s "/usr/${_arch}/include/qt/QtGui/qguiapplication.h" './sysinclude/qtgui/qguiapplication.h'
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} INCLUDEPATH+="${srcdir}/${_pkgfqn}/build-${_arch}/sysinclude"
+ make
+ popd
+ done
done
}
package() {
cd "${srcdir}/${_pkgfqn}"
+
for _arch in ${_architectures}; do
- pushd build-${_arch}
- make INSTALL_ROOT="${pkgdir}" install
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -o -name "*.bat" -o -name "*.def" -o -name "*.exp" -o -name '*.prl' | xargs -rtl1 rm
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
- popd
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
done
}