summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:42 +0200
committerMartchus2020-09-13 13:26:42 +0200
commit0082b196002e0e79a0d17741c4288f9be72c1d84 (patch)
treebf76fc7d8c26347fa2b5e8cc21d0317f87d2d7f9
downloadaur-0082b196002e0e79a0d17741c4288f9be72c1d84.tar.gz
Update to 5.15.1
-rw-r--r--.SRCINFO30
-rw-r--r--0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch41
-rw-r--r--0002-Fix-build-with-ANGLE.patch29
-rw-r--r--0003-Workaround-multiple-definition-errors-with-amstrmid-.patch30
-rw-r--r--PKGBUILD119
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtmultimedia-sha256.txt1
7 files changed, 251 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d53b7ad28219
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = mingw-w64-qt5-multimedia-static
+ pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
+ pkgver = 5.15.1
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = any
+ groups = mingw-w64-qt5
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-qt5-base-static
+ depends = mingw-w64-qt5-declarative-static
+ depends = mingw-w64-qt5-multimedia
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtmultimedia-everywhere-src-5.15.1.tar.xz
+ source = 0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
+ source = 0002-Fix-build-with-ANGLE.patch
+ source = 0003-Workaround-multiple-definition-errors-with-amstrmid-.patch
+ sha256sums = ed6e75bec9c98559c0fbc91ff746185b1e1845139b2c7a5a843e1e8880697d99
+ sha256sums = 98d1157f57558204355b94b2f1fba7cbd9bd9bb561a5d66a0a48ffaab2894569
+ sha256sums = 8e189a64fd15bf2267cb58f3d3c23d0d2ad9eb8c5f07723546d5a6620c5915c3
+ sha256sums = 63860dba39d8c30dad59c0d9b4fc17e4da6e1e212e41520dbb8912e034974a40
+
+pkgname = mingw-w64-qt5-multimedia-static
+
diff --git a/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
new file mode 100644
index 000000000000..5d9c11306888
--- /dev/null
+++ b/0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch
@@ -0,0 +1,41 @@
+From 50c01edfba9e3aaf8c1713e04618de8020cf2a62 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:36:56 +0200
+Subject: [PATCH 1/3] Recorder includes to prevent conflict with vsnprintf
+
+Some files #include <dshow.h>
+This is a C header which also #include's stdio.h which adds a #define vsnprintf
+This #define vsnprint conflicts with QtCore/qstring.h so reorder the includes
+a bit to prevent this situation
+---
+ src/multimedia/video/qvideosurfaceformat.h | 1 +
+ src/plugins/directshow/common/directshowglobal.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/multimedia/video/qvideosurfaceformat.h b/src/multimedia/video/qvideosurfaceformat.h
+index 1d1990c7..8ddffa03 100644
+--- a/src/multimedia/video/qvideosurfaceformat.h
++++ b/src/multimedia/video/qvideosurfaceformat.h
+@@ -44,6 +44,7 @@
+ #include <QtCore/qpair.h>
+ #include <QtCore/qshareddata.h>
+ #include <QtCore/qsize.h>
++#include <QtCore/qstring.h>
+ #include <QtGui/qimage.h>
+ #include <QtMultimedia/qvideoframe.h>
+
+diff --git a/src/plugins/directshow/common/directshowglobal.h b/src/plugins/directshow/common/directshowglobal.h
+index 12693e4f..f759a8f2 100644
+--- a/src/plugins/directshow/common/directshowglobal.h
++++ b/src/plugins/directshow/common/directshowglobal.h
+@@ -43,6 +43,7 @@
+ #include <dshow.h>
+
+ #include <QtCore/qglobal.h>
++#include <QtCore/qstring.h>
+ #include <QtCore/qloggingcategory.h>
+
+ QT_BEGIN_NAMESPACE
+--
+2.28.0
+
diff --git a/0002-Fix-build-with-ANGLE.patch b/0002-Fix-build-with-ANGLE.patch
new file mode 100644
index 000000000000..d03459ba3463
--- /dev/null
+++ b/0002-Fix-build-with-ANGLE.patch
@@ -0,0 +1,29 @@
+From b9604145623a990bb08eb460309e838684a692b1 Mon Sep 17 00:00:00 2001
+From: Jose Santiago <jsantiago@haivision.com>
+Date: Thu, 3 Nov 2016 14:36:10 -0500
+Subject: [PATCH 2/3] Fix build with ANGLE
+
+---
+ src/plugins/common/evr/evrd3dpresentengine.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/plugins/common/evr/evrd3dpresentengine.cpp b/src/plugins/common/evr/evrd3dpresentengine.cpp
+index d8e2da6d..41ef4d96 100644
+--- a/src/plugins/common/evr/evrd3dpresentengine.cpp
++++ b/src/plugins/common/evr/evrd3dpresentengine.cpp
+@@ -50,9 +50,9 @@
+ #include <QOffscreenSurface>
+
+ #ifdef MAYBE_ANGLE
+-# include <qguiapplication.h>
+-# include <qpa/qplatformnativeinterface.h>
+-# include <qopenglfunctions.h>
++# include <QtGui/qguiapplication.h>
++# include <QtGui/qpa/qplatformnativeinterface.h>
++# include <QtGui/qopenglfunctions.h>
+ # include <EGL/eglext.h>
+ #endif
+
+--
+2.28.0
+
diff --git a/0003-Workaround-multiple-definition-errors-with-amstrmid-.patch b/0003-Workaround-multiple-definition-errors-with-amstrmid-.patch
new file mode 100644
index 000000000000..02a2f70cfbf1
--- /dev/null
+++ b/0003-Workaround-multiple-definition-errors-with-amstrmid-.patch
@@ -0,0 +1,30 @@
+From b29f98de79aed3c1905423ba6b1ebbb86eca29bb Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 23 May 2020 15:43:20 +0200
+Subject: [PATCH 3/3] Workaround "multiple definition" errors with
+ amstrmid/strmiids
+
+---
+ src/plugins/directshow/directshow.pro | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/plugins/directshow/directshow.pro b/src/plugins/directshow/directshow.pro
+index 27bb3abb..0cce6f20 100644
+--- a/src/plugins/directshow/directshow.pro
++++ b/src/plugins/directshow/directshow.pro
+@@ -16,8 +16,11 @@ mingw {
+ DEFINES += NO_DSHOW_STRSAFE
+ }
+
++# Link against amstrmid for IID_IMFVideoDeviceID, IID_IMFVideoPresenter, IID_IMFTopologyServiceLookupClient
++# and IID_IMFTopologyServiceLookupClient; add -Wl,--allow-multiple-definition to workaround conflicts with
++# strmiids which contains symbols also required but not provided by amstrmid
+ mingw {
+- LIBS_PRIVATE += -lamstrmid
++ LIBS_PRIVATE += -Wl,--allow-multiple-definition -lamstrmid
+ }
+
+ include(common/common.pri)
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1075650a353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,119 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtmultimedia
+
+_qt_module=qtmultimedia
+pkgname=mingw-w64-qt5-multimedia-static
+pkgver=5.15.1
+pkgrel=1
+arch=('any')
+pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
+depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+url='https://www.qt.io/'
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch'
+ '0002-Fix-build-with-ANGLE.patch'
+ '0003-Workaround-multiple-definition-errors-with-amstrmid-.patch')
+sha256sums=('ed6e75bec9c98559c0fbc91ff746185b1e1845139b2c7a5a843e1e8880697d99'
+ '98d1157f57558204355b94b2f1fba7cbd9bd9bb561a5d66a0a48ffaab2894569'
+ '8e189a64fd15bf2267cb58f3d3c23d0d2ad9eb8c5f07723546d5a6620c5915c3'
+ '63860dba39d8c30dad59c0d9b4fc17e4da6e1e212e41520dbb8912e034974a40')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
+_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
+ make
+ popd
+ done
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
+ # delete duplicate files that are in the shared package
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ for shared_path in "${pkgdir}/usr/${_arch}/"{include,share} "${pkgdir}/usr/${_arch}/lib/"{qt/bin,qt/mkspecs}; do
+ [[ -d $shared_path ]] && rm -fR "$shared_path"
+ done
+ for file in $(find "$pkgdir/usr/$_arch/lib"); do
+ [[ -f "${file##$pkgdir}" ]] && rm "$file"
+ done
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
+
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+ done
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtmultimedia-sha256.txt b/qtmultimedia-sha256.txt
new file mode 100644
index 000000000000..72f3c43681db
--- /dev/null
+++ b/qtmultimedia-sha256.txt
@@ -0,0 +1 @@
+ed6e75bec9c98559c0fbc91ff746185b1e1845139b2c7a5a843e1e8880697d99