summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:33 +0100
committerMartchus2022-03-08 23:35:33 +0100
commit63b17fb3051ab21ae6715c345c733054aae4de64 (patch)
treeb0ed5b09abbd3a52c8085c09d76ee6362da7a579
parent0f54ae4070399a9379644fdf6cf4d2047325592b (diff)
downloadaur-63b17fb3051ab21ae6715c345c733054aae4de64.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89418c681f3e..4af262721c16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-networkauth-static
pkgdesc = Network authentication module (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -10,13 +10,13 @@ pkgbase = mingw-w64-qt5-networkauth-static
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = git
depends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-networkauth
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtnetworkauth-everywhere-src-5.15.2.tar.xz
- sha256sums = fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85
+ source = git+https://invent.kde.org/qt/qt/qtnetworkauth#commit=958db00a2064f77b354b573102ca2c2b2e07529c
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-networkauth-static
-
diff --git a/PKGBUILD b/PKGBUILD
index a5462ad8a4f0..1bb2041422e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_qt_module=qtnetworkauth
pkgname=mingw-w64-qt5-networkauth-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Network authentication module (mingw-w64)"
@@ -18,18 +18,31 @@ depends=('mingw-w64-qt5-base-static')
optdepends=()
makedepends=('mingw-w64-gcc')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=958db00a2064f77b354b573102ca2c2b2e07529c
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"