summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:43 +0100
committerMartchus2020-01-29 19:09:43 +0100
commit11abda9a32868730789191e23b80a06cd57588a2 (patch)
tree5e3e66a916dbd811d94c4eabf1bb52009f123db3
parent7193ea9127e25989baf57e05c07475e1ad06c4ad (diff)
downloadaur-11abda9a32868730789191e23b80a06cd57588a2.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--PKGBUILD.sh.ep14
-rw-r--r--qtquickcontrols2-sha256.txt1
4 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 526c43119cf5..9d7648d4bf06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-quickcontrols2
pkgdesc = Reusable Qt Quick based UI controls to create classic desktop-style user interfaces (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -17,8 +17,8 @@ pkgbase = mingw-w64-qt5-quickcontrols2
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtquickcontrols2-everywhere-src-5.14.0.tar.xz
- sha256sums = 827bf86db44ce4f698f172378313db04e1cb81c593e9342bdd95bb1708f27911
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtquickcontrols2-everywhere-src-5.14.1.tar.xz
+ sha256sums = 52d652c48933cc8416a91138eb6fb4c31625734265671f286b6c0d3e27d120ae
pkgname = mingw-w64-qt5-quickcontrols2
diff --git a/PKGBUILD b/PKGBUILD
index 44c600fd3aae..473c07fe56b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,35 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtquickcontrols2
-pkgname="mingw-w64-qt5-quickcontrols2"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-quickcontrols2
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Reusable Qt Quick based UI controls to create classic desktop-style user interfaces (mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-$pkgver"
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('827bf86db44ce4f698f172378313db04e1cb81c593e9342bdd95bb1708f27911')
+sha256sums=('52d652c48933cc8416a91138eb6fb4c31625734265671f286b6c0d3e27d120ae')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -39,7 +44,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..d4432e100bc7
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,14 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Reusable Qt Quick based UI controls to create classic desktop-style user interfaces (mingw-w64)"
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtquickcontrols2-sha256.txt b/qtquickcontrols2-sha256.txt
new file mode 100644
index 000000000000..22013faa3b70
--- /dev/null
+++ b/qtquickcontrols2-sha256.txt
@@ -0,0 +1 @@
+52d652c48933cc8416a91138eb6fb4c31625734265671f286b6c0d3e27d120ae