summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-12-14 01:06:31 +0100
committerMartchus2017-12-14 01:06:31 +0100
commit41b367f81774f0c0ec2418b44f1f829169d34f44 (patch)
treef668e811d36ad981a44e47df921f7a55c22c9b6a
downloadaur-41b367f81774f0c0ec2418b44f1f829169d34f44.tar.gz
Update to 5.10.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD77
2 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a56a93346fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Thu Dec 14 00:06:31 UTC 2017
+pkgbase = mingw-w64-qt5-remoteobjects
+ pkgdesc = Inter-process communication (IPC) module developed for Qt (mingw-w64)
+ pkgver = 5.10.0
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = i686
+ arch = x86_64
+ groups = mingw-w64-qt5
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-declarative
+ makedepends = mingw-w64-qt5-base-static
+ depends = mingw-w64-qt5-base
+ optdepends = mingw-w64-qt5-declarative: QML bindings
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtremoteobjects-everywhere-src-5.10.0.tar.xz
+ sha256sums = df36a69fdbedf9e3612b60a22222c44a4b227d09be6f543e478dac8ea70f6e05
+
+pkgname = mingw-w64-qt5-remoteobjects
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b2ff65fae7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
+_qt_module=qtremoteobjects
+pkgname="mingw-w64-qt5-remoteobjects"
+pkgver=5.10.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Inter-process communication (IPC) module developed for Qt (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+optdepends=('mingw-w64-qt5-declarative: QML bindings')
+makedepends=('mingw-w64-gcc' 'mingw-w64-qt5-declarative')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+url='https://www.qt.io/'
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('df36a69fdbedf9e3612b60a22222c44a4b227d09be6f543e478dac8ea70f6e05')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+
+ # Search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
+ # hence we need insert those paths manually
+ make qmake_all
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5QmlDevTools.so /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools|-L/usr/lib /usr/$_arch/lib/libQt5QmlDevTools.so|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap ||g" {} \;
+
+ make
+ popd
+ done
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
+ done
+}