summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-12 22:04:52 -0600
committerPhilip A Reimer2015-06-12 22:04:52 -0600
commit360eb8feb95c1269940a49e846382b1cea4a54d7 (patch)
treef7eff1e2e7bc0e34286f5419f2d7be50c6398551
downloadaur-360eb8feb95c1269940a49e846382b1cea4a54d7.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD55
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78725768c954
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-qt5-script
+ pkgdesc = Qt5 for Windows -- QtScript module (mingw-w64)
+ pkgver = 5.4.2
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.4/5.4.2/submodules/qtscript-opensource-src-5.4.2.tar.xz
+ md5sums = a615a02ab48e1e8e94c161d65f6af2ad
+
+pkgname = mingw-w64-qt5-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..229388e14812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+
+_qt_module=qtscript
+pkgname="mingw-w64-qt5-script"
+pkgver=5.4.2
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- QtScript module (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="http://qt-project.org/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('a615a02ab48e1e8e94c161d65f6af2ad')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}