summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:14 +0100
committerMartchus2020-01-29 19:09:14 +0100
commit68d2bf2cdad07bfa6192426c8daab6a3c4fd786d (patch)
tree2379e094de956efc7fcfcfd0bbf165c598ddf555
parentad77c631449ace4639c06aa4dbbd73a83639829d (diff)
downloadaur-68d2bf2cdad07bfa6192426c8daab6a3c4fd786d.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep16
-rw-r--r--qtscript-sha256.txt1
4 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62a627a5c5c2..267621a8f234 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-script
pkgdesc = Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -17,8 +17,8 @@ pkgbase = mingw-w64-qt5-script
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtscript-everywhere-src-5.14.0.tar.xz
- sha256sums = 6715ed5294013edfc338367b63ee6df2438965e4626435f30837e26a2151d3b9
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtscript-everywhere-src-5.14.1.tar.xz
+ sha256sums = d8071e665935f7f6733f5ef700054a0cbbf8b569e7900439b89d3301f70adadd
pkgname = mingw-w64-qt5-script
diff --git a/PKGBUILD b/PKGBUILD
index b31a1fbde658..93b4673c0ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,16 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtscript
-pkgname="mingw-w64-qt5-script"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-script
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)"
@@ -19,16 +23,19 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('6715ed5294013edfc338367b63ee6df2438965e4626435f30837e26a2151d3b9')
+sha256sums=('d8071e665935f7f6733f5ef700054a0cbbf8b569e7900439b89d3301f70adadd')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -39,7 +46,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..b174597bbf6a
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,16 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtscript-sha256.txt b/qtscript-sha256.txt
new file mode 100644
index 000000000000..40637f44cfbb
--- /dev/null
+++ b/qtscript-sha256.txt
@@ -0,0 +1 @@
+d8071e665935f7f6733f5ef700054a0cbbf8b569e7900439b89d3301f70adadd