summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:04 +0100
committerMartchus2022-03-08 23:35:04 +0100
commitd5edec6398f6a6076c66df65c644041872247ea9 (patch)
tree5d1e5a174ebec324f147ea14854d5b05aa0bf017
parent9c44a29debed5505faddee92242a7326db9b1190 (diff)
downloadaur-d5edec6398f6a6076c66df65c644041872247ea9.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--PKGBUILD.sh.ep9
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4384aff6933..16d8aafce9aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-script
pkgdesc = Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.8
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,12 @@ pkgbase = mingw-w64-qt5-script
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtscript-everywhere-src-5.15.2.tar.xz
- sha256sums = a299715369afbd1caa4d7fa2875d442eab91adcaacafce54a36922442624673e
+ source = git+https://code.qt.io/qt/qtscript.git#tag=v5.15.8-lts
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-script
-
diff --git a/PKGBUILD b/PKGBUILD
index 7cc80e216e0f..2bdd72222bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,8 @@
_qt_module=qtscript
pkgname=mingw-w64-qt5-script
-pkgver=5.15.2
+_basever=5.15.3
+pkgver=5.15.8
pkgrel=1
arch=('any')
pkgdesc="Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)"
@@ -20,12 +21,13 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('a299715369afbd1caa4d7fa2875d442eab91adcaacafce54a36922442624673e')
+_pkgfqn=${_qt_module}
+source=(git+https://code.qt.io/qt/$_pkgfqn.git#tag=v${pkgver}-lts)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -88,6 +90,8 @@ package() {
[[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+
+ sed -e "s|$pkgver\ |$_basever |" -i "$pkgdir"/usr/$_arch/lib/cmake/*/*Config.cmake
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 4c505655ea61..83246b9bf718 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -5,7 +5,14 @@
# Contributor: Filip Brcic <brcha@gna.org>
% end
\
-pkgver=5.15.2
+% content_for package_config => begin
+
+ sed -e "s|$pkgver\ |$_basever |" -i "$pkgdir"/usr/$_arch/lib/cmake/*/*Config.cmake
+% end
+% stash(is_lts => 1);
+\
+_basever=5.15.3
+pkgver=5.15.8
pkgrel=1
arch=('any')
pkgdesc="Classes for making Qt applications scriptable. Provided for Qt 4.x compatibility (mingw-w64)"