summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:24 +0100
committerMartchus2022-03-08 23:35:24 +0100
commit0a1bf180be03349ba482050e00d8d89b9f90e5a3 (patch)
treedd9bba16258290f7f8d7b6a4453d0d65e52936bd
parent78f07c2bb13cb08d7eac80d80573ee54c89f759b (diff)
downloadaur-0a1bf180be03349ba482050e00d8d89b9f90e5a3.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e83bc8a13bb..ea201bfaeb79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-scxml
pkgdesc = Static and runtime integration of SCXML models into Qt code (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -12,12 +12,12 @@ pkgbase = mingw-w64-qt5-scxml
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtscxml-everywhere-src-5.15.2.tar.xz
- sha256sums = 60b9590b9a41c60cee7b8a8c8410ee4625f0389c1ff8d79883ec5a985638a7dc
+ source = git+https://invent.kde.org/qt/qt/qtscxml#commit=50d2da3965ed8e85f3f5f5760393c42b12d34a9f
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-scxml
-
diff --git a/PKGBUILD b/PKGBUILD
index 378a2306ae3c..4fbe95e25d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,37 @@
_qt_module=qtscxml
pkgname=mingw-w64-qt5-scxml
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Static and runtime integration of SCXML models into Qt code (mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=50d2da3965ed8e85f3f5f5760393c42b12d34a9f
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('60b9590b9a41c60cee7b8a8c8410ee4625f0389c1ff8d79883ec5a985638a7dc')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 99ec356d49bc..7fd6c9fc8526 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt5-module';
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="Static and runtime integration of SCXML models into Qt code (mingw-w64)"