summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-22 20:36:14 +0200
committerMartchus2016-06-22 20:36:14 +0200
commit6e493399910272fbb6a751227f098b43e958e63c (patch)
treeeb4946eeff4f056988e3bd60d7f3e4e126148701
downloadaur-6e493399910272fbb6a751227f098b43e958e63c.tar.gz
Update to 5.7.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD62
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa34ade291a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Jun 22 18:36:13 UTC 2016
+pkgbase = mingw-w64-qt5-scxml
+ pkgdesc = Static and runtime integration of SCXML models into Qt code (mingw-w64)
+ pkgver = 5.7.0
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtscxml-opensource-src-5.7.0.tar.xz
+ md5sums = 94ef6ad85733a1f9a8d92372ad652da3
+
+pkgname = mingw-w64-qt5-scxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f037283c980
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_qt_module=qtscxml
+pkgname="mingw-w64-qt5-scxml"
+pkgver=5.7.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Static and runtime integration of SCXML models into Qt code (mingw-w64)"
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="https://www.qt.io/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('94ef6ad85733a1f9a8d92372ad652da3')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make qmake_all
+ find ./tools -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
+
+ make
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}