summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-19 22:10:37 +0200
committerMartchus2016-08-19 22:10:37 +0200
commitd9a3f75744a2df87ac414f92955c764eb020b398 (patch)
tree3772ea349b8117ce5d5af3323e9c4f275b96ebf9
parent6e493399910272fbb6a751227f098b43e958e63c (diff)
downloadaur-d9a3f75744a2df87ac414f92955c764eb020b398.tar.gz
Add static version of further Qt modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD62
2 files changed, 39 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa34ade291a5..528607f1ede1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:36:13 UTC 2016
+# Fri Aug 19 20:10:36 UTC 2016
pkgbase = mingw-w64-qt5-scxml
pkgdesc = Static and runtime integration of SCXML models into Qt code (mingw-w64)
pkgver = 5.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = i686
arch = x86_64
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 3f037283c980..533af0775dc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
_qt_module=qtscxml
pkgname="mingw-w64-qt5-scxml"
pkgver=5.7.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="Static and runtime integration of SCXML models into Qt code (mingw-w64)"
depends=('mingw-w64-qt5-declarative')
@@ -20,21 +23,27 @@ _pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
md5sums=('94ef6ad85733a1f9a8d92372ad652da3')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=shared')
-build()
-{
+build() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
-
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make qmake_all
- find ./tools -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
-
- make
- popd
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ make qmake_all
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
+ make
+ popd
+ done
done
}
@@ -42,21 +51,20 @@ package() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
- pushd build-${_arch}
-
- make INSTALL_ROOT="${pkgdir}" install
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
-
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
- strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
-
- popd
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
done
-
- # .prl files aren't interesting for us
- find "${pkgdir}" -name "*.prl" -delete
}