summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:08 +0100
committerMartchus2022-03-08 23:35:08 +0100
commit0ebf5337269d80e21fe40983f5c6c707bb8acdf3 (patch)
tree9e0933098963332942591d51655da9f11f6b5e2e
parent1d406dff3b94c9a3d4b8ceac9045d3d311047071 (diff)
downloadaur-0ebf5337269d80e21fe40983f5c6c707bb8acdf3.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00ed25772122..d1b05fedd96f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-sensors-static
pkgdesc = Provides access to sensor hardware and motion gesture recognition (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,14 +11,14 @@ pkgbase = mingw-w64-qt5-sensors-static
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative-static
depends = mingw-w64-qt5-sensors
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtsensors-everywhere-src-5.15.2.tar.xz
- sha256sums = 3f0011f9e9942cad119146b54d960438f4568a22a274cdad4fae06bb4e0e4839
+ source = git+https://invent.kde.org/qt/qt/qtsensors#commit=975ba788d3d0ee87aa08bb5301cd33dcbf00521b
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-sensors-static
-
diff --git a/PKGBUILD b/PKGBUILD
index 6c7b68ef14a8..489810376425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,25 +11,38 @@
_qt_module=qtsensors
pkgname=mingw-w64-qt5-sensors-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Provides access to sensor hardware and motion gesture recognition (mingw-w64)"
depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=975ba788d3d0ee87aa08bb5301cd33dcbf00521b
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('3f0011f9e9942cad119146b54d960438f4568a22a274cdad4fae06bb4e0e4839')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"