summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:19 +0100
committerMartchus2022-03-08 23:35:19 +0100
commit40904b8dd399240ccd1d3d913432778df7053a3c (patch)
tree24e0d6f51d9d0eb10a3dcb3999b7ddbe4fff5742
parent411ae2941e18606c21381a65c0c492125722b9f2 (diff)
downloadaur-40904b8dd399240ccd1d3d913432778df7053a3c.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c2b6115beee..f2dd94298344 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-serialport
pkgdesc = Provides access to hardware and virtual serial ports (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,12 @@ pkgbase = mingw-w64-qt5-serialport
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtserialport-everywhere-src-5.15.2.tar.xz
- sha256sums = 59c559d748417306bc1b2cf2315c1e63eed011ace38ad92946af71f23e2ef79d
+ source = git+https://invent.kde.org/qt/qt/qtserialport#commit=f95e2411d7c978def87846ea7cedf3dc5fd7c8b8
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-serialport
-
diff --git a/PKGBUILD b/PKGBUILD
index 006dc8a09214..e9fd537dc04d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,24 +10,33 @@
_qt_module=qtserialport
pkgname=mingw-w64-qt5-serialport
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=f95e2411d7c978def87846ea7cedf3dc5fd7c8b8
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('59c559d748417306bc1b2cf2315c1e63eed011ace38ad92946af71f23e2ef79d')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index c96bfd6b4cae..c425536b6a4b 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -4,7 +4,7 @@
# Contributor: ant32 <antreimer@gmail.com>
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"