summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-12 22:05:37 -0600
committerPhilip A Reimer2015-06-12 22:05:37 -0600
commit5f5d175810102590aa67e126f7f9035ffab65b56 (patch)
tree5945604dd88110e8b74f3640b33df11d2a83dd50
downloadaur-5f5d175810102590aa67e126f7f9035ffab65b56.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD63
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5731d75b198b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-qt5-serialport
+ pkgdesc = Qt5 for Windows -- QtSerialPort module (mingw-w64)
+ pkgver = 5.4.2
+ pkgrel = 1
+ url = http://qt-project.org/wiki/QtSerialPort
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.4/5.4.2/submodules/qtserialport-opensource-src-5.4.2.tar.xz
+ md5sums = 546a62eee89722081b7ec13d72469772
+
+pkgname = mingw-w64-qt5-serialport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..347845111ef2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+_qt_module=qtserialport
+pkgname="mingw-w64-qt5-serialport"
+pkgver=5.4.2
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- QtSerialPort module (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('LGPL')
+url="http://qt-project.org/wiki/QtSerialPort"
+_pkgfqn="${_qt_module}-opensource-src-$pkgver"
+source=("http://download.qt-project.org/official_releases/qt/5.4/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
+md5sums=('546a62eee89722081b7ec13d72469772')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # don't build examples or tests.
+ sed -i 's/ examples tests//' qtserialport.pro
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch}/include/QtSerialPort && pushd build-${_arch}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+ popd
+
+ #mkdir -p static-${_arch}/include/QtSerialPort && pushd static-${_arch}
+ #${_arch}-qmake-qt5 ../${_qt_module}.pro CONFIG+=static
+ #make
+ #popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ popd
+
+ #pushd static-${_arch}
+ #make INSTALL_ROOT="${pkgdir}" install
+ #popd
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+ #${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*t.a
+ done
+
+ # .prl files aren't interesting for us
+ find ${pkgdir} -name "*.prl" -delete
+}