summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-02-04 00:01:57 +0100
committerMartchus2016-02-04 00:01:57 +0100
commita40dc1c409d581f85122039f0891d8713a011ad3 (patch)
treee605324c6516e5cce0a3cdaf08b26d62db75587f
parentb19b502d64ee98a8d49d5a0405c74c5db66f1640 (diff)
downloadaur-a40dc1c409d581f85122039f0891d8713a011ad3.tar.gz
updated version (to 5.5.1), URL and description
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--PKGBUILD.bak65
3 files changed, 80 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 577d29f01da5..57ee83dfdcd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 23:01:57 UTC 2016
pkgbase = mingw-w64-qt5-serialport
- pkgdesc = Qt5 for Windows -- QtSerialPort module (mingw-w64)
- pkgver = 5.5.0
+ pkgdesc = Provides access to hardware and virtual serial ports (mingw-w64)
+ pkgver = 5.5.1
pkgrel = 1
- url = http://qt-project.org/wiki/QtSerialPort
+ url = https://www.qt.io/
arch = any
license = LGPL
makedepends = mingw-w64-gcc
@@ -10,8 +12,8 @@ pkgbase = mingw-w64-qt5-serialport
options = !strip
options = !buildflags
options = staticlibs
- source = http://download.qt-project.org/official_releases/qt/5.5/5.5.0/submodules/qtserialport-opensource-src-5.5.0.tar.xz
- md5sums = 8a76f051ed28a9c925d32f5864d33e78
+ source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qtserialport-opensource-src-5.5.1.tar.xz
+ md5sums = 1065424ad9be54f7635a9a50f35bc187
pkgname = mingw-w64-qt5-serialport
diff --git a/PKGBUILD b/PKGBUILD
index 98b83cfb8b28..f7b92f7dd681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Maintainer: ant32 <antreimer@gmail.com>
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+
_qt_module=qtserialport
pkgname="mingw-w64-qt5-serialport"
-pkgver=5.5.0
+pkgver=5.5.1
pkgrel=1
arch=('any')
-pkgdesc="Qt5 for Windows -- QtSerialPort module (mingw-w64)"
+pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc')
options=('!strip' '!buildflags' 'staticlibs')
license=('LGPL')
-url="http://qt-project.org/wiki/QtSerialPort"
+url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-$pkgver"
-source=("http://download.qt-project.org/official_releases/qt/5.5/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
-md5sums=('8a76f051ed28a9c925d32f5864d33e78')
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
+md5sums=('1065424ad9be54f7635a9a50f35bc187')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/PKGBUILD.bak b/PKGBUILD.bak
new file mode 100644
index 000000000000..c175d82ed041
--- /dev/null
+++ b/PKGBUILD.bak
@@ -0,0 +1,65 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+
+_qt_module=qtserialport
+pkgname="mingw-w64-qt5-serialport"
+pkgver=5.5.1
+pkgrel=1
+arch=('any')
+pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('LGPL')
+url="http://qt-project.org/wiki/QtSerialPort"
+_pkgfqn="${_qt_module}-opensource-src-$pkgver"
+source=("http://download.qt-project.org/official_releases/qt/5.5/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
+md5sums=('8a76f051ed28a9c925d32f5864d33e78')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # don't build examples or tests.
+ sed -i 's/ examples tests//' qtserialport.pro
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch}/include/QtSerialPort && pushd build-${_arch}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+ popd
+
+ #mkdir -p static-${_arch}/include/QtSerialPort && pushd static-${_arch}
+ #${_arch}-qmake-qt5 ../${_qt_module}.pro CONFIG+=static
+ #make
+ #popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ popd
+
+ #pushd static-${_arch}
+ #make INSTALL_ROOT="${pkgdir}" install
+ #popd
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+ #${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*t.a
+ done
+
+ # .prl files aren't interesting for us
+ find ${pkgdir} -name "*.prl" -delete
+}