summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:10:32 +0100
committerMartchus2020-01-29 19:10:32 +0100
commitc9494b132b8e7db7643362179e18cf7020b9c6df (patch)
tree4e72cde32b5b1a5b709a4f3902f34f5e7fc871fd
parent8467604474b70274e38c22d271f240a8ba2fba9f (diff)
downloadaur-c9494b132b8e7db7643362179e18cf7020b9c6df.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep13
-rw-r--r--qtspeech-sha256.txt1
4 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccf46d88298a..45808167ad70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-speech
pkgdesc = Qt module to make text to speech and speech recognition easy (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -16,8 +16,8 @@ pkgbase = mingw-w64-qt5-speech
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtspeech-everywhere-src-5.14.0.tar.xz
- sha256sums = c62ba6080a779f8a62e727a33c277cf0744426804f6774e1000bdee0799e7725
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtspeech-everywhere-src-5.14.1.tar.xz
+ sha256sums = abd9a1863a64de0a148ae37e5fdecde7fd486348f7b26c054008f8506223e425
pkgname = mingw-w64-qt5-speech
diff --git a/PKGBUILD b/PKGBUILD
index 092c7daa6019..7b57381f29b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,16 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtspeech
-pkgname="mingw-w64-qt5-speech"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-speech
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Qt module to make text to speech and speech recognition easy (mingw-w64)"
@@ -18,19 +22,20 @@ makedepends=('mingw-w64-gcc')
# mingw-w64-flite and mingw-w64-speech-dispatcher are currently not available
#optdepends=('mingw-w64-flite: flite TTS backend' 'mingw-w64-speech-dispatcher: speech-dispatcher TTS backend')
#makedepends=('mingw-w64-gcc' 'mingw-w64-flite' 'mingw-w64-speech-dispatcher')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('c62ba6080a779f8a62e727a33c277cf0744426804f6774e1000bdee0799e7725')
+sha256sums=('abd9a1863a64de0a148ae37e5fdecde7fd486348f7b26c054008f8506223e425')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -41,7 +46,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..0d85d38eb269
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,13 @@
+% layout 'mingw-w64-qt5-module';
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Qt module to make text to speech and speech recognition easy (mingw-w64)"
+depends=('mingw-w64-qt5-multimedia')
+optdepends=()
+makedepends=('mingw-w64-gcc')
+# mingw-w64-flite and mingw-w64-speech-dispatcher are currently not available
+#optdepends=('mingw-w64-flite: flite TTS backend' 'mingw-w64-speech-dispatcher: speech-dispatcher TTS backend')
+#makedepends=('mingw-w64-gcc' 'mingw-w64-flite' 'mingw-w64-speech-dispatcher')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtspeech-sha256.txt b/qtspeech-sha256.txt
new file mode 100644
index 000000000000..f8d16d9b26b0
--- /dev/null
+++ b/qtspeech-sha256.txt
@@ -0,0 +1 @@
+abd9a1863a64de0a148ae37e5fdecde7fd486348f7b26c054008f8506223e425