summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-04-14 11:37:35 +0200
committerMartchus2021-04-14 11:37:35 +0200
commit36dc9caaa66b5f560a9ea76f5f5dadd00f8629cf (patch)
treeeee60d9145c7815befbbf0f5724c76ab5c72e820
parent29abe26b8e190e38ee869d54c7b069ff2dad0d01 (diff)
downloadaur-36dc9caaa66b5f560a9ea76f5f5dadd00f8629cf.tar.gz
Update to use KDE fork patches
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5455e2152878..5ee07eb099be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-svg
pkgdesc = Classes for displaying the contents of SVG files (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.2+kde+r5
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,13 @@ pkgbase = mingw-w64-qt5-svg
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtsvg-everywhere-src-5.15.2.tar.xz
- sha256sums = 8bc3c2c1bc2671e9c67d4205589a8309b57903721ad14c60ea21a5d06acb585e
+ source = git+https://invent.kde.org/qt/qt/qtsvg#commit=95990cbeebc0ab9959e2a925a93ad4897416bbb7
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-svg
diff --git a/PKGBUILD b/PKGBUILD
index 91d1d3f89a21..b1f71757a9a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,17 +17,31 @@ pkgdesc="Classes for displaying the contents of SVG files (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=95990cbeebc0ab9959e2a925a93ad4897416bbb7
+pkgver+=+kde+r5
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8bc3c2c1bc2671e9c67d4205589a8309b57903721ad14c60ea21a5d06acb585e')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ git revert -n 9aac88424a1b76e0198b52437af58a6d94aff8e9 # Revert version bump
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"