summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:50 +0100
committerMartchus2020-01-29 19:09:50 +0100
commit5a940cff0121b1a8f7513b129aa0de713e4d3799 (patch)
tree3bddfd734855112f3d31d38e5d1cfea5f0affff5
parent287ea1e272e457f6d314eaa1e8faeb2ae56315be (diff)
downloadaur-5a940cff0121b1a8f7513b129aa0de713e4d3799.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep13
-rw-r--r--qtsvg-sha256.txt1
4 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2403a9f7b588..7823c6bf2509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-svg
pkgdesc = Classes for displaying the contents of SVG files (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -17,8 +17,8 @@ pkgbase = mingw-w64-qt5-svg
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtsvg-everywhere-src-5.14.0.tar.xz
- sha256sums = 1ee51a66e1996f96bf7fd4c696079c4cb22ea2bc710d47535c1daf3638d8f393
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtsvg-everywhere-src-5.14.1.tar.xz
+ sha256sums = 8540a57312f815f81a45b891b49959d776727fde17579bb6bf1a537996bc9359
pkgname = mingw-w64-qt5-svg
diff --git a/PKGBUILD b/PKGBUILD
index 86c2e0443adc..936906881a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,35 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtsvg
-pkgname="mingw-w64-qt5-svg"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-svg
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Classes for displaying the contents of SVG files (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('1ee51a66e1996f96bf7fd4c696079c4cb22ea2bc710d47535c1daf3638d8f393')
+sha256sums=('8540a57312f815f81a45b891b49959d776727fde17579bb6bf1a537996bc9359')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -38,7 +43,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..94974ec0cf4e
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,13 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Classes for displaying the contents of SVG files (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtsvg-sha256.txt b/qtsvg-sha256.txt
new file mode 100644
index 000000000000..a1d6e062a23b
--- /dev/null
+++ b/qtsvg-sha256.txt
@@ -0,0 +1 @@
+8540a57312f815f81a45b891b49959d776727fde17579bb6bf1a537996bc9359