summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:15 +0100
committerMartchus2018-02-19 20:15:15 +0100
commita9fc82eb4d2ebf952da75f5d048c5c5f6566cd49 (patch)
treef5671bd69cc60344a6369f98c54c2caab18af0fd
parent20d38fd0061e2bd9f8a2ad8439b28d9df22cb727 (diff)
downloadaur-a9fc82eb4d2ebf952da75f5d048c5c5f6566cd49.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9a9f0a26318..6dfb80e6ff22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:27 UTC 2017
+# Mon Feb 19 19:15:15 UTC 2018
pkgbase = mingw-w64-qt5-svg
pkgdesc = Classes for displaying the contents of SVG files (mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -19,8 +19,8 @@ pkgbase = mingw-w64-qt5-svg
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtsvg-everywhere-src-5.10.0.tar.xz
- sha256sums = 4a2aa7cae70a3156846655422b9ed884d8b08b3707b95858e49c7cf9afe5e7b0
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtsvg-everywhere-src-5.10.1.tar.xz
+ sha256sums = 00e00c04abcc8363cf7d94ca8b16af61840995a4af23685d49fa4ccafa1c7f5a
pkgname = mingw-w64-qt5-svg
diff --git a/PKGBUILD b/PKGBUILD
index 81a5aa00ed49..6c6659753fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtsvg
pkgname="mingw-w64-qt5-svg"
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc="Classes for displaying the contents of SVG files (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('4a2aa7cae70a3156846655422b9ed884d8b08b3707b95858e49c7cf9afe5e7b0')
+sha256sums=('00e00c04abcc8363cf7d94ca8b16af61840995a4af23685d49fa4ccafa1c7f5a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -53,6 +53,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
@@ -64,5 +77,8 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}