summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-04-14 11:37:39 +0200
committerMartchus2021-04-14 11:37:39 +0200
commit13b3178029f563b85705f328b6b29aa97e8130a8 (patch)
tree23c9a3e2795769f48935f405b81c4235d2548afb
parentb57d991a690dda5f2781f25917c7f88788eb486e (diff)
downloadaur-13b3178029f563b85705f328b6b29aa97e8130a8.tar.gz
Update to use KDE fork patches
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
-rw-r--r--qtsvg-sha256.txt2
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1ac6d131937..af22dc7f98ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-svg-static
pkgdesc = Classes for displaying the contents of SVG files (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.2+kde+r5
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,13 +11,14 @@ pkgbase = mingw-w64-qt5-svg-static
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-svg
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtsvg-everywhere-src-5.15.2.tar.xz
- sha256sums = 8bc3c2c1bc2671e9c67d4205589a8309b57903721ad14c60ea21a5d06acb585e
+ source = git+https://invent.kde.org/qt/qt/qtsvg#commit=95990cbeebc0ab9959e2a925a93ad4897416bbb7
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-svg-static
diff --git a/PKGBUILD b/PKGBUILD
index c452946f27d3..b44b0fc63d50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,18 +17,32 @@ pkgdesc="Classes for displaying the contents of SVG files (mingw-w64)"
depends=('mingw-w64-qt5-base-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=95990cbeebc0ab9959e2a925a93ad4897416bbb7
+pkgver+=+kde+r5
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8bc3c2c1bc2671e9c67d4205589a8309b57903721ad14c60ea21a5d06acb585e')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ git revert -n 9aac88424a1b76e0198b52437af58a6d94aff8e9 # Revert version bump
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/qtsvg-sha256.txt b/qtsvg-sha256.txt
index 07f801f0e957..cc2ecb636e3a 100644
--- a/qtsvg-sha256.txt
+++ b/qtsvg-sha256.txt
@@ -1 +1 @@
-8bc3c2c1bc2671e9c67d4205589a8309b57903721ad14c60ea21a5d06acb585e
+SKIP