summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-03-16 19:42:22 +0100
committerMartchus2024-03-16 19:42:22 +0100
commit91c265d15e19a3368b5c1a61770f7a35413c4978 (patch)
tree60aadc431c525588c590993ff27c5a7d03b0eaf3
parent86ae13352c93c15fa1683f87ea8c0d98a9d9f7e3 (diff)
downloadaur-mingw-w64-qt5-tools.tar.gz
Update to 5.15.13
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-linguist-macro.patch4
-rw-r--r--[-rwxr-xr-x]PKGBUILD12
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qttools-sha256.txt2
5 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcf3c05c9841..ba1712ee1585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.12+kde+r4
+ pkgver = 5.15.13+kde+r4
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,9 +20,9 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qttools#commit=bd0ceb7de5d0c918ae596150e95b069dca8b9150
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=ba4c633c4a4731ead0c376b908bf5449796f7de1
source = 0001-Fix-linguist-macro.patch
- sha256sums = SKIP
- sha256sums = d4500aad5ae74b538e307812861391da0df69d74bfff8e18f4a1fb15aaa3c73b
+ sha256sums = 52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf
+ sha256sums = 3c8c553909b394a9d4833116be8a6a6f4a1e267e894fabd925c2519933b25e43
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 92659e447b44..bc19c095ab6e 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 33bb6f7d3e9ba8b91b7756721eb2b16a65c13061 Mon Sep 17 00:00:00 2001
+From f8d57f24ce2dc49fe0dd8e96343f7e66cc61e65c Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -40,5 +40,5 @@ index 0ccf59f3c..01f5f3cd6 100644
DEPENDS ${qm_dep} VERBATIM
)
--
-2.43.0
+2.44.0
diff --git a/PKGBUILD b/PKGBUILD
index a4f90dac104c..08db2377e2db 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,14 +23,14 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=bd0ceb7de5d0c918ae596150e95b069dca8b9150
+_commit=ba4c633c4a4731ead0c376b908bf5449796f7de1
_basever=${pkgver%%+*}
pkgver+=+kde+r4
makedepends+=('git')
@@ -40,8 +40,8 @@ url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
-sha256sums=('SKIP'
- 'd4500aad5ae74b538e307812861391da0df69d74bfff8e18f4a1fb15aaa3c73b')
+sha256sums=('52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf'
+ '3c8c553909b394a9d4833116be8a6a6f4a1e267e894fabd925c2519933b25e43')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -69,7 +69,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -82,7 +82,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index cddfc01bde49..9305a79bee60 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -18,7 +18,7 @@
% end
\
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index cc2ecb636e3a..fa10f9c8d102 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-SKIP
+52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf