summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:34 +0200
committerMartchus2020-09-13 13:26:34 +0200
commit01f451e1496bd159af80d8a9a5198a16509041f0 (patch)
treeb1263c8b8b0b7d1ab27172d038b42b6c13e22e58
parent80bc31426a7310a9e8a8de369f7d914ec7e3db74 (diff)
downloadaur-01f451e1496bd159af80d8a9a5198a16509041f0.tar.gz
Update to 5.15.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-linguist-macro.patch4
-rw-r--r--[-rwxr-xr-x]PKGBUILD16
-rw-r--r--PKGBUILD.sh.ep6
-rw-r--r--qttools-sha256.txt2
5 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81bdefb5d47d..27afa5dea7f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.0
+ pkgver = 5.15.1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -15,15 +15,13 @@ pkgbase = mingw-w64-qt5-tools
makedepends = mingw-w64-postgresql
makedepends = mingw-w64-mariadb-connector-c
makedepends = mingw-w64-vulkan-headers
- makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative
- optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.0/submodules/qttools-everywhere-src-5.15.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qttools-everywhere-src-5.15.1.tar.xz
source = 0001-Fix-linguist-macro.patch
- sha256sums = ddbcb49aab3a2e3672582c6e2e7bec0058feff790f67472343c79e2895e0e437
+ sha256sums = c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498
sha256sums = ca4cdea138d38a8f55a20f4821d35138035115dd1c61ae1b28156d90aa75b38a
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index b47e4280b635..429a07f66f92 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 9d961ddca0caefbc9a218bb40fbf7f27b7b03a2e Mon Sep 17 00:00:00 2001
+From 4b848e15c429260e3c78d897b30dc03adcf23fad Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -38,5 +38,5 @@ index ab271d56..f54c99c4 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.26.2
+2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index 060d7d8973b7..91c119aa4af5 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,12 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
# All patches are managed at https://github.com/Martchus/qttools
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
# For QQuickWidgetPlugin, add mingw-w64-qt5-declarative to dependencies (already present by default)
# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies (mingw-w64-qt5-webkit is no longer updated)
# For QAxWidgetPlugin, add mingw-w64-qt5-activeqt to dependencies
@@ -26,7 +23,7 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
@@ -39,17 +36,12 @@ url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-linguist-macro.patch')
-sha256sums=('ddbcb49aab3a2e3672582c6e2e7bec0058feff790f67472343c79e2895e0e437'
+sha256sums=('c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498'
'ca4cdea138d38a8f55a20f4821d35138035115dd1c61ae1b28156d90aa75b38a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 9fc0f7e81a8e..0226332f5b04 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -18,11 +18,11 @@
% end
\
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
-arch=('i686' 'x86_64')
+arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
-depends=('mingw-w64-qt5-declarative')
+depends=(<%== qt5deps qw(declarative) %>)
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
\
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index c14ded303788..882e147262cd 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-ddbcb49aab3a2e3672582c6e2e7bec0058feff790f67472343c79e2895e0e437
+c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498