summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:12 +0100
committerMartchus2018-02-19 20:15:12 +0100
commit0351b5eef1e505b870a74eb23fb43073399ef332 (patch)
tree5d05e21d67f98fe61d42ccc4ab8c23b5cad9296d
parentfa3bc7e28e60bde6ed76277118d39ce2e9cdfa7b (diff)
downloadaur-0351b5eef1e505b870a74eb23fb43073399ef332.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-linguist-macro.patch10
-rw-r--r--0002-Prevent-linking-qhelpconverter-against-static-bearer.patch4
-rwxr-xr-xPKGBUILD24
4 files changed, 33 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 011ef4eb0b3e..366826f1316c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:22 UTC 2017
+# Mon Feb 19 19:15:12 UTC 2018
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -22,12 +22,12 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qttools-everywhere-src-5.10.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qttools-everywhere-src-5.10.1.tar.xz
source = 0001-Fix-linguist-macro.patch
source = 0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
- sha256sums = 1ff5dc747b7935de85257673424dfdffb231f3409f09a5f833d37e2f625cfe32
- sha256sums = b56db6e1c9aae96ec1fa6949481155972bfd05f0c9b2ffff2ae2216efb459132
- sha256sums = 9395445dd8a9eba7f9b14b3643fdd7e2f0175aa92b1658c6aef9425cb303588c
+ sha256sums = f1ea441e5fe138756e6de3b60ab7d8d3051799eabe85a9408c995dfd4d048a53
+ sha256sums = 3baea410be6981b8dca1d91dc6e2e79ea45ed689b093004fb5616a7fe8023173
+ sha256sums = e76e523c69922995877ee196c5949d277e94db3cd387b6afe4d6313e2ab7e42f
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 0402cd055cec..ddf5da48f9d1 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 03b30c2afe26f192890c741785b072671282caf4 Mon Sep 17 00:00:00 2001
+From 25a07c1c58dab6e2409b060bd00b65cab909b189 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH 1/2] Fix linguist macro
@@ -11,7 +11,7 @@ Subject: [PATCH 1/2] Fix linguist macro
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index 6013cc6e..2e797326 100644
+index 8e363a40..d7fd0f8b 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
@@ -26,8 +26,8 @@ index 6013cc6e..2e797326 100644
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
DEPENDS ${_my_sources} ${_ts_lst_file} VERBATIM)
endforeach()
-@@ -93,8 +95,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
- set(qm "${CMAKE_CURRENT_BINARY_DIR}/${qm}.qm")
+@@ -95,8 +97,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ set(qm "${CMAKE_CURRENT_BINARY_DIR}/${FILE_NAME}.qm")
endif()
+ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
@@ -38,5 +38,5 @@ index 6013cc6e..2e797326 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.15.1
+2.16.1
diff --git a/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
index f2ab1de72ef1..0701147312be 100644
--- a/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
+++ b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
@@ -1,4 +1,4 @@
-From 0521fdd2a6c98c63117345fcf320d1a868153373 Mon Sep 17 00:00:00 2001
+From 289c0b4f16c90e69cd872adbe4b63ddb899c42f1 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 15 Oct 2017 22:25:22 +0200
Subject: [PATCH 2/2] Prevent linking qhelpconverter against static bearer
@@ -27,5 +27,5 @@ index d60aae7c..99943618 100644
SOURCES += conversionwizard.cpp \
inputpage.cpp \
--
-2.15.1
+2.16.1
diff --git a/PKGBUILD b/PKGBUILD
index 4fe00a66ab26..8366d85831a1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
@@ -30,9 +30,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-linguist-macro.patch'
'0002-Prevent-linking-qhelpconverter-against-static-bearer.patch')
-sha256sums=('1ff5dc747b7935de85257673424dfdffb231f3409f09a5f833d37e2f625cfe32'
- 'b56db6e1c9aae96ec1fa6949481155972bfd05f0c9b2ffff2ae2216efb459132'
- '9395445dd8a9eba7f9b14b3643fdd7e2f0175aa92b1658c6aef9425cb303588c')
+sha256sums=('f1ea441e5fe138756e6de3b60ab7d8d3051799eabe85a9408c995dfd4d048a53'
+ '3baea410be6981b8dca1d91dc6e2e79ea45ed689b093004fb5616a7fe8023173'
+ 'e76e523c69922995877ee196c5949d277e94db3cd387b6afe4d6313e2ab7e42f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
# can not use static MySQL plugin because mariadb-connector-c comes with its own pthread implementation
@@ -84,6 +84,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
# Applications might be useful as well; keeping them will not hurt anybody I suppose
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
@@ -107,6 +120,9 @@ package() {
#rm -r "${pkgdir}/usr/${_arch}/share"
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
# Make sure the executables don't conflict with their mingw-qt4 counterpart