summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-02-13 16:57:34 +0100
committerMartchus2017-02-13 16:57:34 +0100
commit06124f9013b8db442b934218ba341feeb728826b (patch)
tree81f6715f0c49ab8810009b00501ad436393c340b
parentd814c489bcadce6d7f1d284b6a66e1649370326b (diff)
downloadaur-06124f9013b8db442b934218ba341feeb728826b.tar.gz
Prevent linking against QtBootstrap from qt5-base
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76a97c001d8c..6ab9d53a3edc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Feb 9 20:00:30 UTC 2017
+# Mon Feb 13 15:57:34 UTC 2017
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
pkgver = 5.8.0
diff --git a/PKGBUILD b/PKGBUILD
index e54c5917def1..7f9430b83ef8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,8 +61,8 @@ build() {
# Search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
# hence we need insert those paths manually
make qmake_all
- find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools|-L/usr/lib -L/usr/$_arch/lib -lQt5QmlDevTools|g" {} \;
- find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools|-L/usr/lib /usr/$_arch/lib/libQt5QmlDevTools.so|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
make
popd