summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-06-14 10:48:27 +0200
committerMartchus2023-06-14 10:48:27 +0200
commit2ef80dc7fdb2fe07c04953e46142cdcbf821e856 (patch)
treee09cf2c507ad1f0328901d23a587f5a146e48ce8
parent16ef7b729be49e40c2eb6b53bb71231238e81629 (diff)
downloadaur-2ef80dc7fdb2fe07c04953e46142cdcbf821e856.tar.gz
Update to 5.15.10
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-linguist-macro.patch14
-rw-r--r--PKGBUILD8
-rw-r--r--PKGBUILD.sh.ep2
4 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed13b3348ceb..014bc75656f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.9+kde+r1
+ pkgver = 5.15.10+kde+r3
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,9 +20,9 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qttools#commit=5649efd376ed7dbb171905e9edebbd547d1f73eb
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=9f7af2d08eea7c2a2a2bfe7e6a9b73d1b99f5123
source = 0001-Fix-linguist-macro.patch
sha256sums = SKIP
- sha256sums = 6b99ea86a90d88227a4758e029e0e99db7ed5e683aec33ac82a49df8790c24e7
+ sha256sums = 54d1369b171cb85550cd7cd7ff37d0aec319164ae6f3236935136adda5527841
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index cdaf252beb2e..bb1e8e8644d1 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 526d7e1fbdd80578a112c2c67ead312278321769 Mon Sep 17 00:00:00 2001
+From 7e93bb1841baab628c38a52c13ca3c7ce30a75ef Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -13,13 +13,13 @@ Change-Id: Ie502d6237f0fed14f377912463f394c8d6ae396d
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index 6a45e57be..c034f2749 100644
+index 0ccf59f3c..01f5f3cd6 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
-@@ -96,8 +96,9 @@ function(QT5_CREATE_TRANSLATION _qm_files)
- file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
+@@ -104,8 +104,9 @@ function(QT5_CREATE_TRANSLATION _qm_files)
+ if(NOT EXISTS "${full_stamp_file_dir}")
+ file(MAKE_DIRECTORY "${full_stamp_file_dir}")
endif()
- set(stamp_file "${stamp_file_dir}/${_ts_name}.stamp")
+ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
add_custom_command(OUTPUT ${stamp_file}
- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
@@ -27,7 +27,7 @@ index 6a45e57be..c034f2749 100644
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
COMMAND ${CMAKE_COMMAND} -E touch "${stamp_file}"
DEPENDS ${_dependencies}
-@@ -146,9 +147,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+@@ -156,9 +157,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
else()
set(qm_dep "${_abs_FILE}")
endif()
@@ -40,5 +40,5 @@ index 6a45e57be..c034f2749 100644
DEPENDS ${qm_dep} VERBATIM
)
--
-2.40.0
+2.41.0
diff --git a/PKGBUILD b/PKGBUILD
index c05ae08b708e..2bc045dba302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,16 +23,16 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools
-pkgver=5.15.9
+pkgver=5.15.10
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=5649efd376ed7dbb171905e9edebbd547d1f73eb
+_commit=9f7af2d08eea7c2a2a2bfe7e6a9b73d1b99f5123
_basever=$pkgver
-pkgver+=+kde+r1
+pkgver+=+kde+r3
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
@@ -41,7 +41,7 @@ _pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
sha256sums=('SKIP'
- '6b99ea86a90d88227a4758e029e0e99db7ed5e683aec33ac82a49df8790c24e7')
+ '54d1369b171cb85550cd7cd7ff37d0aec319164ae6f3236935136adda5527841')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 3d5533ef2e89..87ebf277aa48 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -18,7 +18,7 @@
% end
\
-pkgver=5.15.9
+pkgver=5.15.10
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"